summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-14 11:34:29 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-06-04 17:16:02 +0200
commit50fd603e21c0a278b2dd50bb1174d3d296bba92a (patch)
tree266713300a569bbd5b386242ca71f273d7292c9a /mate-base/mate-common/mate-common-1.18.0.ebuild
parentphp-pear-lib-r1.eclass: Fix usage of @DEAD (diff)
downloadgentoo-50fd603e21c0a278b2dd50bb1174d3d296bba92a.tar.gz
gentoo-50fd603e21c0a278b2dd50bb1174d3d296bba92a.tar.bz2
gentoo-50fd603e21c0a278b2dd50bb1174d3d296bba92a.zip
mate-base/mate-common: Version bump to 1.18.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'mate-base/mate-common/mate-common-1.18.0.ebuild')
-rw-r--r--mate-base/mate-common/mate-common-1.18.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/mate-base/mate-common/mate-common-1.18.0.ebuild b/mate-base/mate-common/mate-common-1.18.0.ebuild
new file mode 100644
index 000000000000..47c9b9f3d9ea
--- /dev/null
+++ b/mate-base/mate-common/mate-common-1.18.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate-desktop.org
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Common files for development of MATE packages"
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+}
+
+src_install() {
+ mv doc-build/README README.doc-build \
+ || die "Failed to rename doc-build/README."
+
+ default
+
+ dodoc doc/usage.txt
+}