summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 00:30:18 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:12:41 -0400
commit8bee9a215746178b8bc4aec012cd69316c0df0de (patch)
treed403af73c2abc53e7791f8b0bd58f025544ca364 /mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild
parentx11-themes/mate-icon-theme-faenza: 1.12.x vbump, import from project repo (diff)
downloadgentoo-8bee9a215746178b8bc4aec012cd69316c0df0de.tar.gz
gentoo-8bee9a215746178b8bc4aec012cd69316c0df0de.tar.bz2
gentoo-8bee9a215746178b8bc4aec012cd69316c0df0de.zip
mate-extra/mate-indicator-applet: 1.12.x vbump, add gtk3, from project repo
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild')
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..0585d9aa084b
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.12.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate versionator
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE indicator applet"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="gtk3"
+
+RDEPEND="
+ >=mate-base/mate-panel-1.8[gtk3(-)=]
+ !gtk3? (
+ >=dev-libs/libindicator-0.3.90:0
+ >=x11-libs/gtk+-2.24:2
+ )
+ gtk3? (
+ >=dev-libs/libindicator-0.3.90:3
+ >=x11-libs/gtk+-3.0:3
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0)
+}