summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-08-14 18:09:20 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-08-17 00:17:21 -0400
commitb64637c46a5d7c17b050e526e1ae2ba9f9321b3c (patch)
treee850608ee000aa0d84816cb3bf0d9c3d0a2e8408 /mate-extra/mate-user-share/mate-user-share-1.22.1.ebuild
parentmate-extra/mate-user-guide: Bump to 1.22.2 (diff)
downloadgentoo-b64637c46a5d7c17b050e526e1ae2ba9f9321b3c.tar.gz
gentoo-b64637c46a5d7c17b050e526e1ae2ba9f9321b3c.tar.bz2
gentoo-b64637c46a5d7c17b050e526e1ae2ba9f9321b3c.zip
mate-extra/mate-user-share: Bump to 1.22.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org> Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'mate-extra/mate-user-share/mate-user-share-1.22.1.ebuild')
-rw-r--r--mate-extra/mate-user-share/mate-user-share-1.22.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/mate-extra/mate-user-share/mate-user-share-1.22.1.ebuild b/mate-extra/mate-user-share/mate-user-share-1.22.1.ebuild
new file mode 100644
index 000000000000..80932af77200
--- /dev/null
+++ b/mate-extra/mate-user-share/mate-user-share-1.22.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Personal file sharing for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.70
+ >=dev-libs/glib-2.50:2
+ >=mate-base/caja-1.17.1
+ media-libs/libcanberra[gtk3]
+ >=sys-apps/dbus-1.1.1
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/pango
+ >=x11-libs/libnotify-0.7
+ virtual/libintl"
+
+RDEPEND="${COMMON_DEPEND}
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2:2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/ \
+ --disable-bluetooth \
+ $(use_with X x)
+}