summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-11-09 22:40:47 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2016-12-08 16:30:16 +0100
commit29cc8d32834314dd0d6e25aa8775ca6114c64f7e (patch)
treea87e5b144bd653ddcb45894f2e9b41a07e08a733 /mate-extra
parentmate-extra/mate-power-manager: version bump to 1.16.0 (diff)
downloadgentoo-29cc8d32834314dd0d6e25aa8775ca6114c64f7e.tar.gz
gentoo-29cc8d32834314dd0d6e25aa8775ca6114c64f7e.tar.bz2
gentoo-29cc8d32834314dd0d6e25aa8775ca6114c64f7e.zip
mate-extra/mate-system-monitor: version bump to 1.16.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.16.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 00ca1c5db74f..3faaefca324f 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,2 +1,3 @@
DIST mate-system-monitor-1.12.2.tar.xz 2114504 SHA256 78b91ae43fd0f06e0577d71d3b92b9c03ff2dc8809ba2b06dc0c4dc9e93683f5 SHA512 f001d36b7a343cba68bf76094abad4e07cc89537c71dba873bb5ffc61045f440a319e3db8d5ee55ff301f52dbdad8b275ca71a4ab6c5fbe34d75c2e65edd7c23 WHIRLPOOL 7270766f4434cb0e489f3f1ef805586987751fbea6a0a020df8fa7fa38dbbf264d0d1f3694fbba8e9d14cf2ddaee217ac562a391b4b87f1033cf2850067ae1a0
DIST mate-system-monitor-1.14.0.tar.xz 2135464 SHA256 ccd7f52836af22d18138e516335ee259448749b6618327feb908ad396d0c650a SHA512 f19fa0241228be8ec8600db43e71495750039288292ba5714489a84acb3e5cc9f4c87d39a63d29a0fc6f907af6ecc319382cd4276ae2de1125bba059d5b24be5 WHIRLPOOL d354dfbf7121b838af6fac73148e381c23df4e3bc50a59f68f6469416f608235a0b6d990214e9de87bc01e1254f16e1ba9d1f631e18554205ae45ebc4b84f149
+DIST mate-system-monitor-1.16.0.tar.xz 2120984 SHA256 abbbfeba699f73a6eacb7545927693daba4fb6203a75170a93df4842cacd9fe1 SHA512 6ee8e1d1a3af5e3b295c2cca74b3e6bdf8a09eb6aa7d63f13db006829c2df25b580b72cc8d6e34e2844b243999cd4f059a42aa67a88c60825defdb7880150796 WHIRLPOOL 2fa9402bab4c9a9441e5dae2094cc12862bf484827f3cd5c238ee234792f03b0a751229c08b81d0def97194e6901f61736747a6656a9738d3bd2f52116e30a70
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.16.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.16.0.ebuild
new file mode 100644
index 000000000000..4f6f946a9d52
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.16.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="systemd"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.36:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/libwnck-3.0:3
+ virtual/libintl:0
+ systemd? ( sys-apps/systemd )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable systemd)
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ einfo "${PN} may run commands with escalated privileges using"
+ einfo "x11-libs/gksu."
+}