summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:28 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:03:23 -0400
commit4baf37fa7791f4cc59907e49ff293693f0fe7f11 (patch)
treecb64f470727e988e2007c79b6a5b82ff944f7591 /mate-extra
parentx11-terms/mate-terminal: Bump to 1.22.1, fix deps (diff)
downloadgentoo-4baf37fa7791f4cc59907e49ff293693f0fe7f11.tar.gz
gentoo-4baf37fa7791f4cc59907e49ff293693f0fe7f11.tar.bz2
gentoo-4baf37fa7791f4cc59907e49ff293693f0fe7f11.zip
mate-extra/mate-utils: Bump to 1.22.1, add missing deps
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-utils/Manifest1
-rw-r--r--mate-extra/mate-utils/mate-utils-1.22.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/mate-extra/mate-utils/Manifest b/mate-extra/mate-utils/Manifest
index e3fec4a73bae..e0ffb67e6acb 100644
--- a/mate-extra/mate-utils/Manifest
+++ b/mate-extra/mate-utils/Manifest
@@ -1 +1,2 @@
DIST mate-utils-1.22.0.tar.xz 7300112 BLAKE2B 8a613b6dcb99e652ad6b44bd64ad9b2f9c809713b5fb904059b64234b51e2a06b2290dcf14d7dde82e8011be2ca395fe74d87bcae5b903b196d55bb50e8fdf07 SHA512 248c6e4108900768a4e8b272d20ac9b2d70e8bf77375f4669a099f4d8386c2e8affeafb772d209f00906f96f20d7ee347167ef4837186f44d8aaad85ef855f70
+DIST mate-utils-1.22.1.tar.xz 7284496 BLAKE2B 83e7e39a0daadae595ab2cc90ad250f61a294afc896df28bf17259cec619af4b0c9d1927c07b03a0cdd7449174af258227678299823169e2cb4d9c4d3ec98c92 SHA512 0f70f088de80440ff6954c899eab75c2bf22d332293c1ec61bf8391396ed31a2ab126279dc4d9dab6f4932225120309bc52e122bcd5a8dc17abccfd6e480390d
diff --git a/mate-extra/mate-utils/mate-utils-1.22.1.ebuild b/mate-extra/mate-utils/mate-utils-1.22.1.ebuild
new file mode 100644
index 000000000000..e77178d5d01e
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.22.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Utilities for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X applet debug ipv6 test"
+
+RDEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4[gtk3]
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )"
+
+DEPEND="${RDEPEND}
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ gnome-base/librsvg
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto"
+
+src_prepare() {
+ # Make apps visible in all DEs.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e '/OnlyShowIn/d' -i {} + || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --disable-maintainer-flags \
+ --enable-zlib \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_with X x) \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6)
+}