summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2024-01-25 12:30:19 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-07 16:45:45 +0200
commit621bbd0fb6695337528199093fb1801867357c8f (patch)
tree5aa4a32181cf36b2cc21e4502d606300ca9589c3 /mate-extra
parentdev-lang/php: drop 8.1.27 (diff)
downloadgentoo-621bbd0fb6695337528199093fb1801867357c8f.tar.gz
gentoo-621bbd0fb6695337528199093fb1801867357c8f.tar.bz2
gentoo-621bbd0fb6695337528199093fb1801867357c8f.zip
mate-extra/mate-system-monitor: add 1.26.3
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35004 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.26.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 8d5263d004bb..aa5e8a08c0d9 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,2 +1,3 @@
DIST mate-system-monitor-1.26.2.tar.xz 2515076 BLAKE2B ca5aa8c80b2b6291a0b0867e4c9cfc93ed0b507cf502dde459a0d04ab9ec3ea59373defd6ecd1b98c903b4adc643c45472d8c9da3c5604d3225c38f0f7c59d1a SHA512 a57052a7f72923ab84aeb584ae2f5c4d9857076ca6cac21ef0e30551d84cdeaa4226fc324c9efc3e06a57ccfcb2fc17ac283aa64f636127a9cd645dbe36690e9
+DIST mate-system-monitor-1.26.3.tar.xz 2516144 BLAKE2B 2bb471152ce1c0739eb4ddc9140878f8830b93216182b6960af996c06f57035c22f3d5ddac37bfc0e5b59742250e823eb8c6de2c00be22c39cf8a2d3e7256e66 SHA512 81158393ca57e7f6cba142341aaae4af475331803d7f304afad8ea634670691a385083dd3ff4f0479fa50bbda2bd0a036656c2aca3dc03e0dc9eeb99db7fec41
DIST mate-system-monitor-1.27.0.tar.xz 2515804 BLAKE2B 08a63af547141c7b6d83bdaa8f02d014f51abe04476c84adfd5f98b0bfd7c2a76b7c13922d9937a30eb26774fcfdc063ab63b3fd048e5b26d299f4aa5d5032d1 SHA512 6eeb8725c538c28b9766aabd0c10d20b8cd31e441452be813759d041125b35251e697acdbdbd786b58cedcf249caf5bb09616c72d27036a6a7b0f3b20ac9e60d
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.26.3.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.26.3.ebuild
new file mode 100644
index 000000000000..69db578ff27d
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.26.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind systemd wnck"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=dev-build/autoconf-2.63:*
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
+ myconf+=(
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}" \
+ $(use_enable wnck)
+}