summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 02:06:06 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 14:11:07 +0300
commit7d985a22be47de34275de69dc4ae52cb3b716ff9 (patch)
tree857af10f5845e1d8310d9531902ede42fd20dbe6 /mate-extra
parentmate-extra/mate-user-share: Version bump (v1.22.0) (diff)
downloadgentoo-7d985a22be47de34275de69dc4ae52cb3b716ff9.tar.gz
gentoo-7d985a22be47de34275de69dc4ae52cb3b716ff9.tar.bz2
gentoo-7d985a22be47de34275de69dc4ae52cb3b716ff9.zip
mate-extra/mate-utils: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-utils/Manifest1
-rw-r--r--mate-extra/mate-utils/mate-utils-1.22.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/mate-extra/mate-utils/Manifest b/mate-extra/mate-utils/Manifest
index d3d3685714f1..4714a8eb079f 100644
--- a/mate-extra/mate-utils/Manifest
+++ b/mate-extra/mate-utils/Manifest
@@ -1 +1,2 @@
DIST mate-utils-1.18.3.tar.xz 6449580 BLAKE2B e8a892d0f924b37da82a8eb233c24b41609831d84fc706ac0082c05cfc0564ca150e6cbd350af8be48acf1e314253e4afe8123bcf4af189a344b3c51e6ccf7d2 SHA512 c9d80e037d32784b3d376aebe23abc6709e14d1df6f293f43c1fc7978f7903ac8b0fc159cebebb3d8dc471df210469b5dcc5dfebdc906ade30a2c7e8f7ca764a
+DIST mate-utils-1.22.0.tar.xz 7300112 BLAKE2B 8a613b6dcb99e652ad6b44bd64ad9b2f9c809713b5fb904059b64234b51e2a06b2290dcf14d7dde82e8011be2ca395fe74d87bcae5b903b196d55bb50e8fdf07 SHA512 248c6e4108900768a4e8b272d20ac9b2d70e8bf77375f4669a099f4d8386c2e8affeafb772d209f00906f96f20d7ee347167ef4837186f44d8aaad85ef855f70
diff --git a/mate-extra/mate-utils/mate-utils-1.22.0.ebuild b/mate-extra/mate-utils/mate-utils-1.22.0.ebuild
new file mode 100644
index 000000000000..cbba18e16de9
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.22.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Utilities for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="X applet debug ipv6 test"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4[gtk3]
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ x11-base/xorg-proto
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Make apps visible in all DEs.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e '/OnlyShowIn/d' -i {} + || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --disable-maintainer-flags \
+ --enable-zlib \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_with X x) \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6)
+}