summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild')
-rw-r--r--media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild b/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild
new file mode 100644
index 000000000000..19c7da19d643
--- /dev/null
+++ b/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit font eutils
+
+DESCRIPTION="Chinese TrueType Arphic Fonts"
+HOMEPAGE="http://www.arphic.com.tw/
+ http://www.freedesktop.org/wiki/Software/CJKUnifonts"
+SRC_URI="mirror://gnu/non-gnu/chinese-fonts-truetype/gkai00mp.ttf.gz
+ mirror://gnu/non-gnu/chinese-fonts-truetype/bkai00mp.ttf.gz
+ mirror://gnu/non-gnu/chinese-fonts-truetype/bsmi00lp.ttf.gz
+ mirror://gnu/non-gnu/chinese-fonts-truetype/gbsn00lp.ttf.gz
+ mirror://ubuntu/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_${PV}.orig.tar.gz
+ mirror://ubuntu/pool/main/t/ttf-arphic-ukai/ttf-arphic-ukai_${PV}.orig.tar.gz"
+
+LICENSE="Arphic"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="media-gfx/fontforge"
+
+S="${WORKDIR}"
+
+#No binaries, only fonts
+RESTRICT="strip binchecks"
+
+FONT_S="${S}"
+FONT_SUFFIX="ttc ttf"
+FONT_CONF=( "25-ttf-arphic-ukai-render.conf"
+ "35-ttf-arphic-ukai-aliases.conf"
+ "41-ttf-arphic-ukai.conf"
+ "75-ttf-arphic-ukai-select.conf"
+ "90-ttf-arphic-ukai-embolden.conf"
+ "25-ttf-arphic-uming-bitmaps.conf"
+ "25-ttf-arphic-uming-render.conf"
+ "35-ttf-arphic-uming-aliases.conf"
+ "41-ttf-arphic-uming.conf"
+ "64-ttf-arphic-uming.conf"
+ "90-ttf-arphic-uming-embolden.conf" )
+
+src_unpack() {
+ #All of this is to ensure that we don't overwrite one font's docs
+ #with another's.
+
+ unpack {gk,bk}ai00mp.ttf.gz {bsmi,gbsn}00lp.ttf.gz
+ mkdir "${WORKDIR}"/{uming,ukai}
+
+ cd "${WORKDIR}"/uming
+ unpack ttf-arphic-uming_${PV}.orig.tar.gz
+
+ cd "${WORKDIR}"/ukai
+ unpack ttf-arphic-ukai_${PV}.orig.tar.gz
+}
+
+src_prepare() {
+ cd "${WORKDIR}"
+ find "${WORKDIR}" -mindepth 2 -maxdepth 2 -name '*.ttc' -exec mv {} . \;
+ find "${WORKDIR}" -name '*.conf' -exec mv "{}" . \;
+ epatch "${FILESDIR}"/${P}-fontconfig.patch
+ fontforge -script "${FILESDIR}"/${P}.pe b*.ttf || die
+}
+
+src_install() {
+ local myfont doc
+ for myfont in ukai uming
+ do
+ cd "${WORKDIR}"/${myfont}
+ docinto ${myfont}
+ for doc in FONTLOG KNOWN_ISSUES TODO README README.Bitmap NEWS CONTRIBUTERS
+ do
+ [ -f ${doc} ] && dodoc ${doc}
+ done
+ done
+ cd "${S}"
+ font_src_install
+}