summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/cronyx-fonts/cronyx-fonts-2.3.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/cronyx-fonts/cronyx-fonts-2.3.1-r2.ebuild')
-rw-r--r--media-fonts/cronyx-fonts/cronyx-fonts-2.3.1-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-fonts/cronyx-fonts/cronyx-fonts-2.3.1-r2.ebuild b/media-fonts/cronyx-fonts/cronyx-fonts-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..be9a4ae3e526
--- /dev/null
+++ b/media-fonts/cronyx-fonts/cronyx-fonts-2.3.1-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Cronyx Cyrillic bitmap fonts for X"
+HOMEPAGE="http://koi8.pp.ru/frame.html?xwin.html#xwin_fonts"
+S="${WORKDIR}/cyrillic"
+SRC_URI="http://koi8.pp.ru/dist/x6rus-${PV}-bin.tgz"
+KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="freedist"
+DEPEND="x11-apps/mkfontdir"
+RDEPEND=""
+IUSE=""
+
+FONT_ROOT=/usr/share/fonts/cronyx
+FONT_TARGETS="75dpi 100dpi misc"
+
+src_install() {
+ for dir in ${FONT_TARGETS}; do
+ insinto ${FONT_ROOT}/$dir
+ doins ${dir}/*.pcf.gz
+ done
+ # our install dir is still ${FONT_ROOT}/misc, so
+ doins misc/fonts.alias
+ dodoc xrus.info
+}
+
+rebuild_fontfiles() {
+ einfo "Refreshing fonts.scale and fonts.dir..."
+ cd ${FONT_ROOT}
+ mkfontdir -- ${FONT_TARGETS}
+ if [ "${ROOT}" = "/" ] && [ -x /usr/bin/fc-cache ]
+ then
+ einfo "Updating font cache..."
+ HOME="/root" /usr/bin/fc-cache -f ${FONT_TARGETS}
+ fi
+}
+
+pkg_postinst() {
+ if use X > /dev/null ; then
+ rebuild_fontfiles
+ elog "In order to make X see the fonts, you need to add the"
+ elog "following lines to the files section of your "
+ elog "/etc/X11/XF86Config (or the XOrg equivalent):"
+ elog " FontPath \"${FONT_ROOT}/100dpi/:unscaled\""
+ elog " FontPath \"${FONT_ROOT}/misc/:unscaled\""
+ elog " FontPath \"${FONT_ROOT}/75dpi/:unscaled\""
+ elog ""
+ elog "In order to make them accessible to your current X"
+ elog "session, run:"
+ elog " xset fp+ ${FONT_ROOT}/100dpi/:unscaled,\\"
+ elog "${FONT_ROOT}/misc/:unscaled,\\"
+ elog "${FONT_ROOT}/75dpi/:unscaled"
+ elog " xset fp rehash"
+ fi
+}
+
+pkg_postrm() {
+ if use X > /dev/null ; then
+ rebuild_fontfiles
+ fi
+}