summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/culmus/culmus-0.120-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/culmus/culmus-0.120-r4.ebuild')
-rw-r--r--media-fonts/culmus/culmus-0.120-r4.ebuild177
1 files changed, 177 insertions, 0 deletions
diff --git a/media-fonts/culmus/culmus-0.120-r4.ebuild b/media-fonts/culmus/culmus-0.120-r4.ebuild
new file mode 100644
index 000000000000..e9b3308f419d
--- /dev/null
+++ b/media-fonts/culmus/culmus-0.120-r4.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit font
+
+# Maintainer: also check culmus.conf file in ${P}.tar.gz
+
+MY_A_P=AncientSemiticFonts-0.06-1
+# The Type 1 fonts are just a stripped version of TrueType fonts and they are
+# not updated unless there is a meaningful change and we need them for
+# culmus-latex, see bug #350657
+TYPE1_PV=0.105
+
+DESCRIPTION="Hebrew Type1 fonts"
+HOMEPAGE="http://culmus.sourceforge.net/"
+
+FANCY_FONTS="journal hillel anka comix gan ozrad ktav-yad dorian gladia horev"
+FANCY_YG_FONTS="ShmuelCLM MakabiYG"
+TAAMEY_FONTS="TaameyDavidCLM TaameyFrankCLM KeterAramTsova KeterYG"
+
+SRC_URI="mirror://sourceforge/culmus/${P}.tar.gz
+ mirror://sourceforge/culmus/${PN}-type1-${TYPE1_PV}.tar.gz
+ fontforge? ( mirror://sourceforge/culmus/${PN}-src-${PV}.tar.gz )
+ ancient? ( !fontforge? ( mirror://sourceforge/culmus/${MY_A_P}.TTF.tgz )
+ fontforge? ( mirror://sourceforge/culmus/${MY_A_P}.tgz ) )"
+SRC_URI+=" fancy? ( $(printf "http://culmus.sourceforge.net/fancy/%s.tar.gz " ${FANCY_FONTS}) )"
+SRC_URI+=" fancy? ( $(printf "http://culmus.sourceforge.net/fancy-yg/%s.zip " ${FANCY_YG_FONTS}) )"
+SRC_URI+=" taamey? ( $(printf "http://culmus.sourceforge.net/taamim/%s.zip " ${TAAMEY_FONTS}) )"
+
+# Some fonts are available in otf format too. Do we need them?
+# http://culmus.sourceforge.net/fancy/anka-otf.zip
+# http://culmus.sourceforge.net/fancy/hillel-otf.zip
+# http://culmus.sourceforge.net/fancy/journal-otf.zip
+
+LICENSE="|| ( GPL-2 LICENSE-BITSTREAM ) ancient? ( MIT ) fancy? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="ancient fancy fontforge taamey"
+
+FONT_CONF=( "${T}/65-culmus.conf" )
+
+RDEPEND="!media-fonts/culmus-ancient"
+# >=x11-apps/mkfontscale-1.0.9-r1 as Heavy weight support is required
+DEPEND="${RDEPEND}
+ >=x11-apps/mkfontscale-1.0.9-r1
+ fontforge? ( media-gfx/fontforge )"
+
+S=${WORKDIR}
+# Put all fonts, generated or not here
+FONT_S=${S}/FONTS
+
+src_unpack() {
+ unpack ${P}.tar.gz # For type1 fonts...
+ unpack ${PN}-type1-${TYPE1_PV}.tar.gz
+ use fontforge && unpack ${PN}-src-${PV}.tar.gz
+
+ use ancient && unpack ${MY_A_P}$(use fontforge || echo .TTF).tgz
+
+ if use fancy; then
+ unpack $(printf "%s.tar.gz " ${FANCY_FONTS})
+ unpack $(printf "%s.zip " ${FANCY_YG_FONTS})
+ mv TTF/* .
+ fi
+
+ if use taamey; then
+ for font in ${TAAMEY_FONTS}; do
+ mkdir ${font}
+ pushd ${font}
+ unpack ${font}.zip
+ popd >/dev/null
+ done
+ fi
+}
+
+src_prepare() {
+ cp "${P}/culmus.conf" "${T}/65-culmus.conf" || die
+}
+
+src_compile() {
+ mkdir -p "${FONT_S}"
+ if use fontforge; then
+ pushd ${P}
+ mv *.afm *.pfa "${FONT_S}"
+ rm *.ttf
+ popd >/dev/null
+
+ pushd ${PN}-type1-${TYPE1_PV}
+ mv *.afm *.pfa "${FONT_S}"
+ popd >/dev/null
+
+ pushd ${PN}-src-${PV}
+ for f in *.sfd; do
+ "${WORKDIR}"/${PN}-src-${PV}/GenerateTTF.pe ${f} "${FONT_S}" || die
+ done
+ popd >/dev/null
+
+ if use ancient; then
+ pushd ${MY_A_P}/src
+ export FONTFORGE_LANGUAGE=ff
+ make clean
+ make all || die "Failed to build fonts"
+ mv *.ttf "${FONT_S}"
+ popd >/dev/null
+ fi
+
+ if use taamey; then
+ for font in ${TAAMEY_FONTS}; do
+ rm -rf ${font}/TTF
+ pushd ${font}/SFD
+ for f in *.sfd; do
+ "${WORKDIR}"/${PN}-src-${PV}/GenerateTTF.pe ${f} "${FONT_S}" || die
+ done
+ popd >/dev/null
+ done
+ fi
+ else
+ pushd ${P}
+ mv *.afm *.pfa *.ttf "${FONT_S}"
+ popd >/dev/null
+
+ pushd ${PN}-type1-${TYPE1_PV}
+ mv *.afm *.pfa "${FONT_S}"
+ popd >/dev/null
+
+ if use ancient; then
+ pushd ${MY_A_P}$(use fontforge || echo .TTF)/fonts
+ mv *.ttf "${FONT_S}"
+ popd >/dev/null
+ fi
+
+ if use taamey; then
+ for font in ${TAAMEY_FONTS}; do
+ pushd ${font}/TTF
+ mv *.ttf "${FONT_S}"
+ popd >/dev/null
+ done
+ fi
+ fi
+
+ use fancy && mv *.afm *.pfa *.ttf "${FONT_S}"
+}
+
+src_install() {
+ FONT_SUFFIX="pfa afm $((use fancy || use taamey) && echo ttf)" \
+ font_src_install
+
+ rm -rf "${FONT_S}"
+ find "${WORKDIR}" -name '*.ttf' -o -name '*.pfa' -o -name '*.pfm' |
+ while read font; do
+ ewarn "QA: missed font file: ${font}"
+ done
+
+ pushd ${PN}$(use fontforge && echo -src)-${PV}
+ dodoc CHANGES || die
+ popd >/dev/null
+
+ if use ancient; then
+ pushd "${WORKDIR}/${MY_A_P}$(use fontforge || echo .TTF)/"
+ newdoc CHANGES{,.ancient} || die
+ newdoc README{,.ancient} || die
+ popd >/dev/null
+ fi
+
+ if use taamey; then
+ for font in ${TAAMEY_FONTS}; do
+ pushd ${font}
+ [[ -f ChangeLog ]] && { newdoc ChangeLog{,.${font}} || die; }
+ newdoc README{,.${font}} || die
+ insinto /usr/share/doc/${PF}/${font}
+ doins -r Samples
+ popd >/dev/null
+ done
+ fi
+}