summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/droid/droid-113-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/droid/droid-113-r3.ebuild')
-rw-r--r--media-fonts/droid/droid-113-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-fonts/droid/droid-113-r3.ebuild b/media-fonts/droid/droid-113-r3.ebuild
new file mode 100644
index 000000000000..ff2952a207d6
--- /dev/null
+++ b/media-fonts/droid/droid-113-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit font
+
+MY_PN="${PN/d/D}"
+
+# $PV is a build number, use fontforge to find it out. 113 was taken from:
+# http://android.git.kernel.org/?p=platform/frameworks/base.git;a=tree;f=data/fonts;hb=HEAD
+DESCRIPTION="Font family from Google's Android project"
+HOMEPAGE="http://code.google.com/android/RELEASENOTES.html http://www.cosmix.org/software/"
+SRC_URI="mirror://gentoo/${P}-r1.tar.bz2
+ mirror://gentoo/${MY_PN}SansMonoSlashed-112_p1.ttf.bz2
+ mirror://gentoo/${MY_PN}SansMonoDotted-112_p1.ttf.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+FONT_S="${S}"
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ "${FILESDIR}/59-google-droid-sans-mono.conf"
+ "${FILESDIR}/59-google-droid-sans.conf"
+ "${FILESDIR}/59-google-droid-serif.conf"
+)
+
+src_prepare() {
+ mv "${WORKDIR}/${MY_PN}SansMonoSlashed-112_p1.ttf" \
+ "${S}/${MY_PN}SansMonoSlashed.ttf"
+ mv "${WORKDIR}/${MY_PN}SansMonoDotted-112_p1.ttf" \
+ "${S}/${MY_PN}SansMonoDotted.ttf"
+}