summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2017-01-20 11:59:51 -0200
committerGuilherme Amadio <amadio@gentoo.org>2017-01-20 12:01:19 -0200
commitaa208bcf25579108b93b1d983d5ddf2c93b8e7f1 (patch)
tree518eb9d692059b83c98e8baac7b6417e689f73ee /media-fonts/hack/hack-2.020-r1.ebuild
parentdev-libs/libgit2: Remove old (diff)
downloadgentoo-aa208bcf25579108b93b1d983d5ddf2c93b8e7f1.tar.gz
gentoo-aa208bcf25579108b93b1d983d5ddf2c93b8e7f1.tar.bz2
gentoo-aa208bcf25579108b93b1d983d5ddf2c93b8e7f1.zip
media-fonts/hack: distribute TTF files instead of OTF (bug #604814)
Gentoo-Bug: https://bugs.gentoo.org/604814 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-fonts/hack/hack-2.020-r1.ebuild')
-rw-r--r--media-fonts/hack/hack-2.020-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-fonts/hack/hack-2.020-r1.ebuild b/media-fonts/hack/hack-2.020-r1.ebuild
new file mode 100644
index 000000000000..ad7ee5ed7537
--- /dev/null
+++ b/media-fonts/hack/hack-2.020-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit font versionator
+
+DESCRIPTION="A typeface designed for source code"
+HOMEPAGE="https://github.com/chrissimpkins/Hack"
+SRC_URI="https://github.com/chrissimpkins/Hack/releases/download/v${PV}/Hack-v$(replace_version_separator 1 '_' )-ttf.tar.xz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND=""
+RDEPEND=""
+
+FONT_SUFFIX="ttf"
+
+src_unpack() {
+ mkdir "${S}" && cd "${S}"
+ unpack ${A}
+}