summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-01-24 19:40:36 +0100
committerPacho Ramos <pacho@gentoo.org>2021-01-24 19:42:04 +0100
commitf45daca86639478b38d3d28f069f7423115fc5c0 (patch)
treebb822d17c09356b5db40068f0fc1dc581a04946b /media-fonts/noto/noto-20201226.ebuild
parentRevert "sys-libs/db: remove old" (diff)
downloadgentoo-f45daca86639478b38d3d28f069f7423115fc5c0.tar.gz
gentoo-f45daca86639478b38d3d28f069f7423115fc5c0.tar.bz2
gentoo-f45daca86639478b38d3d28f069f7423115fc5c0.zip
media-fonts/noto: New snapshot
In sync with newer snapshot in Arch Linux Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts/noto/noto-20201226.ebuild')
-rw-r--r--media-fonts/noto/noto-20201226.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-fonts/noto/noto-20201226.ebuild b/media-fonts/noto/noto-20201226.ebuild
new file mode 100644
index 000000000000..439c26108925
--- /dev/null
+++ b/media-fonts/noto/noto-20201226.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlefonts/noto-fonts"
+
+COMMIT="2b1fbc36600ccd8becb9f894922f644bff2cbc9b"
+SRC_URI="https://github.com/googlei18n/noto-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://www.google.com/get/noto/
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/${PN}-fonts-${COMMIT}"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-unhinted install-hinted || die
+ mv unhinted/ttf/Noto*/*.tt[fc] install-unhinted/. || die
+ mv hinted/ttf/Noto*/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-unhinted/" font_src_install
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.ttf
+}