summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2017-07-08 17:56:18 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2017-07-08 17:56:18 +0200
commitcf0362dd5e54a0013d2e1662a60c7808a1f4c7f9 (patch)
treeabfe1693a6450d4cf094e00168b4ce47756fa036 /media-gfx/aaphoto/aaphoto-0.45.ebuild
parentnet-misc/sks: Cleanup old (diff)
downloadgentoo-cf0362dd5e54a0013d2e1662a60c7808a1f4c7f9.tar.gz
gentoo-cf0362dd5e54a0013d2e1662a60c7808a1f4c7f9.tar.bz2
gentoo-cf0362dd5e54a0013d2e1662a60c7808a1f4c7f9.zip
media-gfx/aaphoto: Version bump to 0.45
Proxied commit Gentoo-Proxied-Maintainer: Ferenc Erki Gentoo-Bug: 624262 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-gfx/aaphoto/aaphoto-0.45.ebuild')
-rw-r--r--media-gfx/aaphoto/aaphoto-0.45.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/aaphoto/aaphoto-0.45.ebuild b/media-gfx/aaphoto/aaphoto-0.45.ebuild
new file mode 100644
index 000000000000..4d3d37cab6f8
--- /dev/null
+++ b/media-gfx/aaphoto/aaphoto-0.45.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatic color correction and resizing of photos"
+HOMEPAGE="http://log69.com/aaphoto.html https://github.com/log69/aaphoto"
+SRC_URI="http://log69.com/downloads/${PN}_sources_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 2 ]] ) \
+ && die "Sorry, but gcc 4.2 or higher is required"
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}