summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-08-02 22:13:40 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-03 17:47:47 +0300
commitfa426a81732eebf31e85e90286e19c1e1ed3fbca (patch)
treef6b4d435f50d88defe2a3ce8b47cbff60ad68f9c /media-gfx/alembic/files
parentapp-antivirus/clamav-unofficial-sigs: new version 6.0.1. (diff)
downloadgentoo-fa426a81732eebf31e85e90286e19c1e1ed3fbca.tar.gz
gentoo-fa426a81732eebf31e85e90286e19c1e1ed3fbca.tar.bz2
gentoo-fa426a81732eebf31e85e90286e19c1e1ed3fbca.zip
media-gfx/alembic: fix a boost_python variable
The patch fixes an issue when USE=test is used, where the python version suffix was not used in a variable. Closes: https://bugs.gentoo.org/691300 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12602 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/alembic/files')
-rw-r--r--media-gfx/alembic/files/alembic-1.7.11-0006-python-PyAlembic-Tests-CMakeLists.txt-fix-variable.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/alembic/files/alembic-1.7.11-0006-python-PyAlembic-Tests-CMakeLists.txt-fix-variable.patch b/media-gfx/alembic/files/alembic-1.7.11-0006-python-PyAlembic-Tests-CMakeLists.txt-fix-variable.patch
new file mode 100644
index 000000000000..6bb8090344f1
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.11-0006-python-PyAlembic-Tests-CMakeLists.txt-fix-variable.patch
@@ -0,0 +1,29 @@
+From 13b88370a862e16b417e9df6e40c2a9cba10852c Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Fri, 2 Aug 2019 21:31:03 +0200
+Subject: [PATCH] python/PyAlembic/Tests/CMakeLists.txt: fix variable
+
+The patch fixes a boost_python related variable which didn't had
+the version suffix for python.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ python/PyAlembic/Tests/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/python/PyAlembic/Tests/CMakeLists.txt b/python/PyAlembic/Tests/CMakeLists.txt
+index c32a018..ed9b23d 100644
+--- a/python/PyAlembic/Tests/CMakeLists.txt
++++ b/python/PyAlembic/Tests/CMakeLists.txt
+@@ -57,7 +57,7 @@ TARGET_LINK_LIBRARIES(PyAlembic_Test Alembic::Alembic ${ALEMBIC_PYILMBASE_LIBS})
+
+ ADD_TEST(PyAlembic_Python_TEST PyAlembic_Test)
+
+-GET_FILENAME_COMPONENT(BOOST_LIBRARY_DIR ${Boost_PYTHON_LIBRARY} PATH)
++GET_FILENAME_COMPONENT(BOOST_LIBRARY_DIR ${Boost_PYTHON27_LIBRARY} PATH)
+ GET_FILENAME_COMPONENT(ILMBASE_LIBRARY_DIR ${ALEMBIC_ILMBASE_IMATH_LIB} PATH)
+
+ CONFIGURE_FILE(
+--
+2.22.0
+