summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 19:59:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 19:59:16 +0100
commit96a214b1fd9c4daeefadaadcd452b9741167a30c (patch)
tree52a0fe92bb3c22d73d693236a34f56b9a994bd0e /media-gfx/alembic
parentsci-libs/lrslib: Drop 042c-r2 and 051 (diff)
downloadgentoo-96a214b1fd9c4daeefadaadcd452b9741167a30c.tar.gz
gentoo-96a214b1fd9c4daeefadaadcd452b9741167a30c.tar.bz2
gentoo-96a214b1fd9c4daeefadaadcd452b9741167a30c.zip
media-gfx/alembic: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/alembic-1.7.11.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/media-gfx/alembic/alembic-1.7.11.ebuild b/media-gfx/alembic/alembic-1.7.11.ebuild
index a306c9ea3d73..eaf86523653f 100644
--- a/media-gfx/alembic/alembic-1.7.11.ebuild
+++ b/media-gfx/alembic/alembic-1.7.11.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils multiprocessing python-single-r1
+inherit cmake multiprocessing python-single-r1
DESCRIPTION="Open framework for storing and sharing scene data"
HOMEPAGE="https://www.alembic.io/"
@@ -50,7 +50,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use doc; then
doxygen -u Doxyfile || die "Failed to update Doxyfile"
sed -i -e 's|DOT_NUM_THREADS[ \t]*= 0|DOT_NUM_THREADS = '$(makeopts_jobs)'|' Doxyfile || die "Failed to change dot threads"
@@ -73,11 +73,11 @@ src_configure() {
-DUSE_PYALEMBIC=$(usex python)
-DUSE_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc; then
doxygen Doxyfile || die "Failed to build documentation"
fi
@@ -85,7 +85,7 @@ src_compile() {
src_install() {
use doc && local HTML_DOCS=( doc/html/. )
- cmake-utils_src_install
+ cmake_src_install
}
pkg_postinst() {