summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/aoi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/aoi')
-rw-r--r--media-gfx/aoi/Manifest4
-rw-r--r--media-gfx/aoi/aoi-2.5.ebuild49
-rw-r--r--media-gfx/aoi/aoi-2.7.2.ebuild50
-rw-r--r--media-gfx/aoi/files/aoi31
-rw-r--r--media-gfx/aoi/metadata.xml8
5 files changed, 142 insertions, 0 deletions
diff --git a/media-gfx/aoi/Manifest b/media-gfx/aoi/Manifest
new file mode 100644
index 000000000000..aafc192dbcd2
--- /dev/null
+++ b/media-gfx/aoi/Manifest
@@ -0,0 +1,4 @@
+DIST aoi25.zip 4529346 SHA256 4b2fef9afa9015fda0d6b7e8fa684d83081f0c83f184330c9432cbd5ccda5231
+DIST aoi272.zip 4733701 SHA256 d5850d13f8fda8f7708676492c9bc9e3471889a7f19f28cae6f1e191de17325e
+DIST manual2.3.zip 11511867 SHA256 d517bf915c5382cec7ef98aff84f9d6eea60e137cbd7e4a83c9d2e02d7b56de3
+DIST manual2.6.zip 13402007 SHA256 b99d249af1e578ebaaa6e4270eed8062e4c9cd2f50e60cd2c26f646076d575e0
diff --git a/media-gfx/aoi/aoi-2.5.ebuild b/media-gfx/aoi/aoi-2.5.ebuild
new file mode 100644
index 000000000000..9873f952a9ca
--- /dev/null
+++ b/media-gfx/aoi/aoi-2.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 eutils
+
+MY_P="aoi25"
+MY_MANUAL_V="2.3"
+S="${WORKDIR}/ArtOfIllusion25"
+DESCRIPTION="A free, open-source 3D modelling and rendering studio"
+SRC_URI="mirror://sourceforge/aoi/${MY_P}.zip
+ doc? ( mirror://sourceforge/aoi/manual${MY_MANUAL_V}.zip )"
+HOMEPAGE="http://aoi.sourceforge.net/index"
+KEYWORDS="~amd64 ~ppc x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+IUSE="doc"
+
+src_install() {
+ # documentation
+ dodoc HISTORY README
+ if use doc ; then
+ mv "${WORKDIR}"/AoI\ Manual/ "${WORKDIR}"/aoi_manual
+ dohtml -r "${WORKDIR}"/aoi_manual/
+ fi
+
+ # main app
+ java-pkg_dojar ArtOfIllusion.jar
+
+ # run script
+ java-pkg_dolauncher aoi \
+ --jar ArtOfIllusion.jar \
+ --java_args -Xmx128M
+
+ # plugins
+ mv Plugins "${D}"/usr/share/${PN}/lib
+
+ # scripts
+ mv Scripts "${D}"/usr/share/${PN}/lib
+
+ # icon
+ mv Icons/64x64.png Icons/aoi.png
+ doicon Icons/aoi.png
+
+ # desktop entry
+ make_desktop_entry aoi "Art of Illusion" aoi "Graphics"
+}
diff --git a/media-gfx/aoi/aoi-2.7.2.ebuild b/media-gfx/aoi/aoi-2.7.2.ebuild
new file mode 100644
index 000000000000..b8c8d069543c
--- /dev/null
+++ b/media-gfx/aoi/aoi-2.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 eutils versionator
+
+MY_V=$(delete_all_version_separators)
+MY_P="aoi${MY_V}"
+MY_MANUAL_V="2.6"
+S="${WORKDIR}/ArtOfIllusion${MY_V}"
+DESCRIPTION="A free, open-source 3D modelling and rendering studio"
+SRC_URI="mirror://sourceforge/aoi/${MY_P}.zip
+ doc? ( mirror://sourceforge/aoi/manual${MY_MANUAL_V}.zip )"
+HOMEPAGE="http://aoi.sourceforge.net/index"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+IUSE="doc"
+
+src_install() {
+ # documentation
+ dodoc HISTORY README
+ if use doc ; then
+ mv "${WORKDIR}"/AoI\ Manual/ "${WORKDIR}"/aoi_manual
+ dohtml -r "${WORKDIR}"/aoi_manual/
+ fi
+
+ # main app
+ java-pkg_dojar ArtOfIllusion.jar
+
+ # run script
+ java-pkg_dolauncher aoi \
+ --jar ArtOfIllusion.jar \
+ --java_args -Xmx128M
+
+ # plugins
+ mv Plugins "${D}"/usr/share/${PN}/lib
+
+ # scripts
+ mv Scripts "${D}"/usr/share/${PN}/lib
+
+ # icon
+ mv Icons/64x64.png Icons/aoi.png
+ doicon Icons/aoi.png
+
+ # desktop entry
+ make_desktop_entry aoi "Art of Illusion" aoi "Graphics"
+}
diff --git a/media-gfx/aoi/files/aoi b/media-gfx/aoi/files/aoi
new file mode 100644
index 000000000000..e7f56707c606
--- /dev/null
+++ b/media-gfx/aoi/files/aoi
@@ -0,0 +1,31 @@
+#!/bin/sh
+# Art Of Illusion Launch Script
+# Author: Dylan Carlson
+# May 2003
+# $Id$
+
+JAVA_HOME=`/usr/bin/java-config --jdk-home`
+if [ -z "${JAVA_HOME}" ] ; then
+ JAVA_HOME=`/usr/bin/java-config --jre-home`
+fi
+CLASSPATH="${CLASSPATH}:`/usr/bin/java-config --classpath=aoi`"
+
+if [ ! -f ${JAVA_HOME}/bin/java ] ; then
+ echo " "
+ echo "I tried using the following Java Runtime:"
+ echo "${JAVA_HOME}/bin/java"
+ echo " "
+ echo "Java Runtime missing. Please run java-config(1) and ensure"
+ echo "your environment is configured properly."
+ exit 1
+else
+ echo " "
+ echo "Using Java Runtime:"
+ echo "${JAVA_HOME}/bin/java"
+ echo " "
+ echo "Using CLASSPATH:"
+ echo "${CLASSPATH}"
+ echo " "
+fi
+
+${JAVA_HOME}/bin/java -Xmx128M -jar /usr/share/aoi/lib/ArtOfIllusion.jar $*
diff --git a/media-gfx/aoi/metadata.xml b/media-gfx/aoi/metadata.xml
new file mode 100644
index 000000000000..670266a8b580
--- /dev/null
+++ b/media-gfx/aoi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">aoi</remote-id>
+ </upstream>
+</pkgmetadata>