summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/apngdis/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/apngdis/files')
-rw-r--r--media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch10
-rw-r--r--media-gfx/apngdis/files/apngdis-2.6-makefile.patch17
2 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch b/media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch
new file mode 100644
index 000000000000..cabf3efed742
--- /dev/null
+++ b/media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- apngdis-2.6-src/apngdis.cpp
++++ apngdis-2.6-src/apngdis.cpp
+@@ -29,6 +29,7 @@
+ */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+ #include <vector>
+ #include "png.h" /* original (unpatched) libpng is ok */
+ #include "zlib.h"
diff --git a/media-gfx/apngdis/files/apngdis-2.6-makefile.patch b/media-gfx/apngdis/files/apngdis-2.6-makefile.patch
new file mode 100644
index 000000000000..ada1cc89a23f
--- /dev/null
+++ b/media-gfx/apngdis/files/apngdis-2.6-makefile.patch
@@ -0,0 +1,17 @@
+--- apngdis-2.6-src/Makefile
++++ apngdis-2.6-src/Makefile
+@@ -1,11 +1,10 @@
+ PACKAGE = apngdis
+-CC = gcc
+-CFLAGS = -Wall -pedantic
+-CFLAGS_OPT = -O2
++CCX ?= g++
++CFLAGS += -Wall -pedantic
+ LIBS = -lstdc++ -lm -lpng -lz
+
+ all :
+- $(CC) $(CFLAGS) $(CFLAGS_OPT) -o apngdis apngdis.cpp -s $(LIBS)
++ $(CXX) $(CFLAGS) $(LDFLAGS) -o apngdis apngdis.cpp $(LIBS)
+
+ .PHONY : clean
+