summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-03-23 07:39:27 +0100
committerHanno Böck <hanno@gentoo.org>2020-03-23 07:39:27 +0100
commitb3360574b336c1e20185c43441170d170d59e877 (patch)
tree8d151adfe6adfcdbcd95688b21500f10185f9ebe /media-gfx/cropgui/cropgui-0.4.1.ebuild
parentsys-apps/portage: Bump to version 2.3.95 (diff)
downloadgentoo-b3360574b336c1e20185c43441170d170d59e877.tar.gz
gentoo-b3360574b336c1e20185c43441170d170d59e877.tar.bz2
gentoo-b3360574b336c1e20185c43441170d170d59e877.zip
media-gfx/cropgui: Re-add cropgui.
This version is python 3 compatible. Bug: https://bugs.gentoo.org/708098 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.94, Repoman-2.3.21
Diffstat (limited to 'media-gfx/cropgui/cropgui-0.4.1.ebuild')
-rw-r--r--media-gfx/cropgui/cropgui-0.4.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/cropgui/cropgui-0.4.1.ebuild b/media-gfx/cropgui/cropgui-0.4.1.ebuild
new file mode 100644
index 000000000000..867b72d6161a
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit eutils python-r1 desktop xdg-utils
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="https://emergent.unpythonic.net/01248401946"
+SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ python_moduleinto "${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}