summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Perlov <perlovka@gmail.com>2018-07-12 13:24:01 +0300
committerAmy Liffey <amynka@gentoo.org>2018-07-16 18:07:20 +0100
commita20ab210d9b3343065d129557d6337f1006f188b (patch)
tree0a1c684847c49d6715f41c211606ef3b48654fbd /media-gfx/curaengine/curaengine-3.4.1.ebuild
parentmedia-gfx/fdm-materials: version bump to 3.4.1 (diff)
downloadgentoo-a20ab210d9b3343065d129557d6337f1006f188b.tar.gz
gentoo-a20ab210d9b3343065d129557d6337f1006f188b.tar.bz2
gentoo-a20ab210d9b3343065d129557d6337f1006f188b.zip
media-gfx/curaengine: version bump to 3.4.1
Bug: https://bugs.gentoo.org/660884 Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'media-gfx/curaengine/curaengine-3.4.1.ebuild')
-rw-r--r--media-gfx/curaengine/curaengine-3.4.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/curaengine/curaengine-3.4.1.ebuild b/media-gfx/curaengine/curaengine-3.4.1.ebuild
new file mode 100644
index 000000000000..2f945665c4a1
--- /dev/null
+++ b/media-gfx/curaengine/curaengine-3.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_PN="CuraEngine"
+
+DESCRIPTION="A 3D model slicing engine for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/CuraEngine"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:*
+ dev-libs/protobuf"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( README.md )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=( "-DBUILD_TESTS=$(usex test ON OFF)" )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_make
+ if use doc; then
+ doxygen
+ mv docs/html . || die
+ find html -name '*.md5' -or -name '*.map' -delete || die
+ DOCS+=( html )
+ fi
+}