summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarshall Brewer (Gentoo Key) <tomboy64@sina.cn>2016-04-30 09:56:35 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-08-07 21:34:01 -0400
commit926306e30a97823ca59c5a12d63e67f241ae3f36 (patch)
treec42f08210f3a4c834ec94812edbf17c19c78e497 /media-gfx/curaengine
parentmedia-gfx/cura: new version 0.15.04.5_rc5 (legacy) (diff)
downloadgentoo-926306e30a97823ca59c5a12d63e67f241ae3f36.tar.gz
gentoo-926306e30a97823ca59c5a12d63e67f241ae3f36.tar.bz2
gentoo-926306e30a97823ca59c5a12d63e67f241ae3f36.zip
media-gfx/curaengine: new version 0.15.04.6 (legacy)
based on the original ebuild by _AxS_ Package-Manager: portage-2.2.28
Diffstat (limited to 'media-gfx/curaengine')
-rw-r--r--media-gfx/curaengine/Manifest1
-rw-r--r--media-gfx/curaengine/curaengine-0.15.04.6.ebuild50
-rw-r--r--media-gfx/curaengine/files/curaengine-0.15.04.6-cflags.patch27
3 files changed, 78 insertions, 0 deletions
diff --git a/media-gfx/curaengine/Manifest b/media-gfx/curaengine/Manifest
index 1d3316c750f6..7d5427e7a9b2 100644
--- a/media-gfx/curaengine/Manifest
+++ b/media-gfx/curaengine/Manifest
@@ -1 +1,2 @@
+DIST curaengine-0.15.04.6.tar.gz 107970 SHA256 4f2e3c5e74001b39cf5894a1e3f436a7724be0ae9ee30cd02bd2e3fd676ca4b1 SHA512 150e93dca08c57bc37af4c3232c0d18aed93347657d7261f89d7d8352d2774ac7a2a944c3b1efce432b507674f5e99981844823b792ec3fbe47799d2487e899d WHIRLPOOL bb37368709d5399ccb5241ff6b8108d7faffc7e8e8b3b155b28f51b2c4cb00fbafc1ea5c3e2198d007036069bc3cf311755c932ae2f01c2cbaa9caba8dada637
DIST curaengine-2.1.0_beta.tar.gz 33322580 SHA256 0db6ca118637972546b04f672bc0cbecbe29b772a3586c7ca5441dc4ae7a7c85 SHA512 23b1e1116fad8e75354a92b8320a228a0b7acb03bcdffa175b8b6f47af0b8af099efdc3c75f840d172fc157d432a05c741a5028f3b8da1e7fc1dd8cf158115fb WHIRLPOOL 45520cf601b5ee2e2845e69f85d051f426317bc38c69b7d1dfe2632bb211b39d7286a747d9d0963e4d20d13c0def8d50dd69fdaf0a027187ec2ad9fd717c13fe
diff --git a/media-gfx/curaengine/curaengine-0.15.04.6.ebuild b/media-gfx/curaengine/curaengine-0.15.04.6.ebuild
new file mode 100644
index 000000000000..7abf5a3b4377
--- /dev/null
+++ b/media-gfx/curaengine/curaengine-0.15.04.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_PV=${PV#0.}
+MY_PN=CuraEngine
+
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A 3D model slicing engine for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/CuraEngine"
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+
+src_prepare() {
+ tc-export CXX
+ default
+}
+
+src_test() {
+ pushd tests 2>&- || die
+ einfo "Commencing test ..."
+ local testbin=( "${S}/build/CuraEngine" "-c" "supportAngle=60" "-c" "supportEverywhere=1" )
+ local testmdl="${S}/tests/testModel.stl"
+ ${testbin[*]} "${testmdl}"
+ if [[ $? -eq 0 && -f "${testbin[0]}" && -f "${testmdl}" ]]; then
+ einfo "Test completed successfully."
+ else
+ ewarn "Test failed."
+ fi
+ popd 2>&- || die
+}
+
+src_install() {
+ dobin build/CuraEngine
+ dodoc README.md
+}
diff --git a/media-gfx/curaengine/files/curaengine-0.15.04.6-cflags.patch b/media-gfx/curaengine/files/curaengine-0.15.04.6-cflags.patch
new file mode 100644
index 000000000000..9807301e462c
--- /dev/null
+++ b/media-gfx/curaengine/files/curaengine-0.15.04.6-cflags.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile b/Makefile
+index 32fa704..c426ef8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,9 +18,9 @@ endif
+ ifeq ($(BUILD_TYPE),PROFILE)
+ CFLAGS+= -pg
+ endif
+-ifeq ($(BUILD_TYPE),RELEASE)
+- CFLAGS+= -O3 -fomit-frame-pointer
+-endif
++#ifeq ($(BUILD_TYPE),RELEASE)
++# CFLAGS+= -O3 -fomit-frame-pointer
++#endif
+
+ LDFLAGS += -Lbuild/ -lclipper
+
+# By courtesy of Whissi: this enforces use of our CXXFLAGS
+@@ -70,7 +70,7 @@ $(BUILD_DIR)/libclipper.a: $(LIBS_DIR)/clipper/clipper.cpp
+ $(CXX) $(CFLAGS) -o $(BUILD_DIR)/libclipper.a $(LIBS_DIR)/clipper/clipper.cpp
+
+ $(EXECUTABLE): $(OBJECTS) $(BUILD_DIR)/libclipper.a
+- $(CXX) $(OBJECTS) -o $@ $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJECTS) -o $@
+
+ $(DIRS):
+ -@$(MKDIR_PREFIX) $(DIRS)