summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Inches <craig@craiginches.com>2016-05-17 03:53:07 +0800
committerPatrice Clement <monsieurp@gentoo.org>2016-05-16 21:18:10 +0000
commitc935e15638b547a48b2dc85f317bf8f2229a67d6 (patch)
tree6158426b0dc381fae978bee2f9cdf549b64812d5 /media-gfx/displaycal
parentnet-nntp/nzbget: re-add a missing patch for old versions (diff)
downloadgentoo-c935e15638b547a48b2dc85f317bf8f2229a67d6.tar.gz
gentoo-c935e15638b547a48b2dc85f317bf8f2229a67d6.tar.bz2
gentoo-c935e15638b547a48b2dc85f317bf8f2229a67d6.zip
media-gfx/displaycal: Version Bump, Rename, and removal of old versions.
Gentoo-Bug: https://bugs.gentoo.org/576440 Gentoo-Bug: https://bugs.gentoo.org/532008 Closes: https://github.com/gentoo/gentoo/pull/1477 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-gfx/displaycal')
-rw-r--r--media-gfx/displaycal/Manifest2
-rw-r--r--media-gfx/displaycal/displaycal-3.0.6.0.ebuild79
-rw-r--r--media-gfx/displaycal/displaycal-3.1.2.0.ebuild79
-rw-r--r--media-gfx/displaycal/metadata.xml18
4 files changed, 178 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
new file mode 100644
index 000000000000..60fffe126e6f
--- /dev/null
+++ b/media-gfx/displaycal/Manifest
@@ -0,0 +1,2 @@
+DIST DisplayCAL-3.0.6.0.tar.gz 16228 SHA256 ff19c4299e33a587103ab475d136e446bfc7a5b631c8b90563227fe6b9898077 SHA512 003110ddb26b01e1517a2605d341649600b64dfa4b55c3cb8e38b5160c5d2b0d876ae76e6a5b4571740b0030c3c713958bc1d7723d5c0c31e626ac4c702e91ee WHIRLPOOL 30ebaf130f0ae3765fd2ada8852d4bd9443ce24b3b53cdd3c111abe9d5b4715e42214ddf69747b2dc806f119106f93436d3f894fc0dcf00c5748b701f08af8a7
+DIST DisplayCAL-3.1.2.0.tar.gz 9361108 SHA256 78dbfd2be1cf7542657cc0f5ed9e16e27558206a4878ffae5ce68bd62460680d SHA512 2c14ed0230e6bdd6f8876a5e8887498e3005941e2f68aedad2926f9b8dda642e909f9aa70205977123b1b7c1376dd3f361ad08ecc5015bfae77342ff1b848837 WHIRLPOOL 74f311618190974e6e9c0c5b895ab7f0dba18de06e52dcf1cca4df0373a278b4c4e170b6add51bdf550b21499ff1ecf249cae6f2eb2f3e0813c666bd0bc4f941
diff --git a/media-gfx/displaycal/displaycal-3.0.6.0.ebuild b/media-gfx/displaycal/displaycal-3.0.6.0.ebuild
new file mode 100644
index 000000000000..5fd3dff316f3
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.0.6.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="https://dispcalgui.hoech.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+ # Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ # Remove x-world Media Type
+ cd "${S}/misc" || die "Cannot cd to misc directory."
+ sed -e 's/x\-world\/x\-vrml\;//g' -i "dispcalGUI-VRML-to-X3D-converter.desktop" \
+ || die "removing x-world media type failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/displaycal/displaycal-3.1.2.0.ebuild b/media-gfx/displaycal/displaycal-3.1.2.0.ebuild
new file mode 100644
index 000000000000..0d69de973612
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.1.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/DisplayCAL" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+ # Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ # Remove x-world Media Type
+ cd "${S}/misc" || die "Cannot cd to misc directory."
+ sed -e 's/x\-world\/x\-vrml\;//g' -i "displaycal-vrml-to-x3d-converter.desktop" \
+ || die "removing x-world media type failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/displaycal/metadata.xml b/media-gfx/displaycal/metadata.xml
new file mode 100644
index 000000000000..f6bd44277424
--- /dev/null
+++ b/media-gfx/displaycal/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@xayto.net</email>
+ <name>Craig Inches</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">dispcalgui</remote-id>
+ </upstream>
+</pkgmetadata>