summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/duhdraw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/duhdraw')
-rw-r--r--media-gfx/duhdraw/Manifest1
-rw-r--r--media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild31
-rw-r--r--media-gfx/duhdraw/files/duhdraw-2.8.13-macos.patch12
-rw-r--r--media-gfx/duhdraw/files/duhdraw-2.8.13-prestrip.patch18
-rw-r--r--media-gfx/duhdraw/metadata.xml5
5 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/duhdraw/Manifest b/media-gfx/duhdraw/Manifest
new file mode 100644
index 000000000000..2ca978b52fe7
--- /dev/null
+++ b/media-gfx/duhdraw/Manifest
@@ -0,0 +1 @@
+DIST duhdraw-2.8.13.tar.gz 51779 SHA256 12a432d2874a6f0579879e3242d832139b7f2a4879b2cfcfb6ced046236b4b2c SHA512 fa9102133dcd100b2cde58d4d92aabfcdf86bb16a8066191e92922d6cea470094ff226e569bf92d34e1f0f6a3e657eaf3326cecf091ed1bc37bd2faace340798 WHIRLPOOL d0adabe102251c2c6c7287a1466de1525e18f1c74d6df1b4a444c15fbdc5dc4ddbc822d11069d9c6f0cff18bbd60daa408dbcc74b058f647b31b9dc8cdc749d3
diff --git a/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild b/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
new file mode 100644
index 000000000000..b7cd4238d1de
--- /dev/null
+++ b/media-gfx/duhdraw/duhdraw-2.8.13-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ASCII art editor"
+HOMEPAGE="http://www.cs.helsinki.fi/u/penberg/duhdraw"
+SRC_URI="http://www.cs.helsinki.fi/u/penberg/duhdraw/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-macos.patch
+ epatch "${FILESDIR}"/${P}-prestrip.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin ansi ansitoc duhdraw
+ dodoc CREDITS HISTORY TODO
+}
diff --git a/media-gfx/duhdraw/files/duhdraw-2.8.13-macos.patch b/media-gfx/duhdraw/files/duhdraw-2.8.13-macos.patch
new file mode 100644
index 000000000000..30be358e46d3
--- /dev/null
+++ b/media-gfx/duhdraw/files/duhdraw-2.8.13-macos.patch
@@ -0,0 +1,12 @@
+--- ./duhdraw-2.8.13/duhdraw.c.orig 2005-03-02 09:22:46.000000000 +0100
++++ ./duhdraw-2.8.13/duhdraw.c 2006-11-16 09:56:21.000000000 +0100
+@@ -12,7 +12,9 @@
+ #include <stdio.h>
+ #include <dirent.h>
+ #include <sys/stat.h>
++#ifndef __APPLE__
+ #include <malloc.h>
++#endif
+ #include <time.h>
+ #include <curses.h>
+ #include <ctype.h>
diff --git a/media-gfx/duhdraw/files/duhdraw-2.8.13-prestrip.patch b/media-gfx/duhdraw/files/duhdraw-2.8.13-prestrip.patch
new file mode 100644
index 000000000000..0162f39370aa
--- /dev/null
+++ b/media-gfx/duhdraw/files/duhdraw-2.8.13-prestrip.patch
@@ -0,0 +1,18 @@
+--- ./duhdraw-2.8.13/Makefile.orig 2005-03-02 09:22:46.000000000 +0100
++++ ./duhdraw-2.8.13/Makefile 2006-11-16 09:58:29.000000000 +0100
+@@ -12,15 +12,12 @@
+
+ ansi: cleanansi
+ $(CC) -o ansi ansi.c ansi-esc.c $(LIBS)
+- $(STRIP) ansi
+
+ duhdraw: cleandd
+ $(CC) -o duhdraw duhdraw.c ansi-esc.c $(LIBS)
+- $(STRIP) duhdraw
+
+ ansitoc: cleanansitoc
+ $(CC) -o ansitoc ansitoc.c
+- $(STRIP) ansitoc
+
+ cleanansi:
+ rm -f ansi
diff --git a/media-gfx/duhdraw/metadata.xml b/media-gfx/duhdraw/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/duhdraw/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>