summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-01-27 16:27:42 +0000
committerDavid Seifert <soap@gentoo.org>2017-01-28 14:46:22 +0100
commit3edfb6ad50d294cb812ef2c3088a39bdcd282fc6 (patch)
tree7a56a7ea6bf5662dcaacf74d95d9a4ec0cea37ec /media-gfx/enblend
parentdev-util/cmake: Remove 3.7.1 (diff)
downloadgentoo-3edfb6ad50d294cb812ef2c3088a39bdcd282fc6.tar.gz
gentoo-3edfb6ad50d294cb812ef2c3088a39bdcd282fc6.tar.bz2
gentoo-3edfb6ad50d294cb812ef2c3088a39bdcd282fc6.zip
media-gfx/enblend: Fix sandbox access violations
The new version of ImageMagick needs access to /dev/dri for image rendering, thus causing the installation of enblend to fail. Signed-off by: Jonathan Scruggs (j.scruggs@gmail.com) Closes: https://github.com/gentoo/gentoo/pull/3682
Diffstat (limited to 'media-gfx/enblend')
-rw-r--r--media-gfx/enblend/enblend-4.2.0_p20161007.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/media-gfx/enblend/enblend-4.2.0_p20161007.ebuild b/media-gfx/enblend/enblend-4.2.0_p20161007.ebuild
index 0c86b86757d1..aa15cce946f4 100644
--- a/media-gfx/enblend/enblend-4.2.0_p20161007.ebuild
+++ b/media-gfx/enblend/enblend-4.2.0_p20161007.ebuild
@@ -67,7 +67,12 @@ src_configure() {
}
src_compile() {
+ # To allow icon resizing with renderers (no way to disable)
+ addpredict /dev/dri
+
+ # To compile fonts in the temp directory
export VARTEXFONTS="${T}/fonts"
+
# forcing -j1 as every parallel compilation process needs about 1 GB RAM.
cmake-utils_src_compile -j1
}