summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 16:23:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 16:23:34 +0100
commitcdb23e8b3608be50daebdeb5d904b179a58d8339 (patch)
tree040107b2234855a7135f6dd2cae7a3e7ecda856a /media-gfx/exiv2/files/exiv2-0.25-tools-optional.patch
parentdev-db/postgresql: arm stable, bug #636978 (diff)
downloadgentoo-cdb23e8b3608be50daebdeb5d904b179a58d8339.tar.gz
gentoo-cdb23e8b3608be50daebdeb5d904b179a58d8339.tar.bz2
gentoo-cdb23e8b3608be50daebdeb5d904b179a58d8339.zip
media-gfx/exiv2: Security cleanup
Bug: https://bugs.gentoo.org/621028 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-gfx/exiv2/files/exiv2-0.25-tools-optional.patch')
-rw-r--r--media-gfx/exiv2/files/exiv2-0.25-tools-optional.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/media-gfx/exiv2/files/exiv2-0.25-tools-optional.patch b/media-gfx/exiv2/files/exiv2-0.25-tools-optional.patch
deleted file mode 100644
index 2bb030a4c4f2..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.25-tools-optional.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/CMakeLists.txt 2015-06-15 17:32:21.000000000 +0200
-+++ b/CMakeLists.txt 2015-10-04 14:37:05.319679836 +0200
-@@ -55,6 +55,7 @@
- OPTION( EXIV2_ENABLE_WEBREADY "Build webready support into library" OFF )
- OPTION( EXIV2_ENABLE_CURL "USE Libcurl for HttpIo" ON )
- OPTION( EXIV2_ENABLE_SSH "USE Libssh for SshIo" ON )
-+OPTION( EXIV2_ENABLE_TOOLS "Build exiv2 executable" ON )
-
- IF( MINGW OR UNIX )
- IF ( CMAKE_CXX_COMPILER STREQUAL "g++" OR CMAKE_C_COMPILER STREQUAL "gcc" )
---- a/src/CMakeLists.txt 2015-06-14 11:12:19.000000000 +0200
-+++ b/src/CMakeLists.txt 2015-10-04 14:33:27.784399402 +0200
-@@ -296,9 +296,11 @@
-
- # ******************************************************************************
- # exiv2 application
--ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} )
--TARGET_LINK_LIBRARIES( exiv2 exiv2lib )
--INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
-+IF( EXIV2_ENABLE_TOOLS )
-+ ADD_EXECUTABLE( exiv2 ${EXIV2_SRC} )
-+ TARGET_LINK_LIBRARIES( exiv2 exiv2lib )
-+ INSTALL( TARGETS exiv2 ${INSTALL_TARGET_STANDARD_ARGS} )
-+ENDIF( EXIV2_ENABLE_TOOLS )
-
- # ******************************************************************************
- # connection test application