summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 13:57:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:43 +0100
commit4204aed71ec2d1b2413df056e74191a61c393e53 (patch)
tree16b5bd4eebd1657716b36eca8e4c399a1bcf8638 /media-gfx/exiv2
parentcmake-multilib.eclass: Add CMAKE_ECLASS switch (diff)
downloadgentoo-4204aed71ec2d1b2413df056e74191a61c393e53.tar.gz
gentoo-4204aed71ec2d1b2413df056e74191a61c393e53.tar.bz2
gentoo-4204aed71ec2d1b2413df056e74191a61c393e53.zip
*/*: Switch kde proj packages using cmake-multilib.eclass to cmake
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/exiv2-0.27.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-gfx/exiv2/exiv2-0.27.2.ebuild b/media-gfx/exiv2/exiv2-0.27.2.ebuild
index 3d6060c5535e..b1ac0f0a6b3d 100644
--- a/media-gfx/exiv2/exiv2-0.27.2.ebuild
+++ b/media-gfx/exiv2/exiv2-0.27.2.ebuild
@@ -11,6 +11,7 @@ else
KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
fi
+CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit cmake-multilib python-any-r1
@@ -59,7 +60,7 @@ src_prepare() {
iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
mv -f doc/cmd.txt.tmp doc/cmd.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
}
@@ -79,11 +80,11 @@ multilib_src_configure() {
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if multilib_is_native_abi; then
use doc && eninja doc