summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-02 13:39:59 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-02 13:39:59 +0100
commit74a318ef1a3a4a9152224a3313183bd32c514367 (patch)
treed89df75418ba69e20525677fcc6be28611233ab2 /media-gfx/figurine
parentapp-portage/pram: Bump to v10 (diff)
downloadgentoo-74a318ef1a3a4a9152224a3313183bd32c514367.tar.gz
gentoo-74a318ef1a3a4a9152224a3313183bd32c514367.tar.bz2
gentoo-74a318ef1a3a4a9152224a3313183bd32c514367.zip
media-gfx/figurine: Port to EAPI 7
Closes: https://bugs.gentoo.org/707666 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/figurine')
-rw-r--r--media-gfx/figurine/figurine-1.0.5-r1.ebuild18
-rw-r--r--media-gfx/figurine/files/figurine-1.0.5-fno-common.patch115
2 files changed, 123 insertions, 10 deletions
diff --git a/media-gfx/figurine/figurine-1.0.5-r1.ebuild b/media-gfx/figurine/figurine-1.0.5-r1.ebuild
index 7c6fffe4dba9..1895738ddc54 100644
--- a/media-gfx/figurine/figurine-1.0.5-r1.ebuild
+++ b/media-gfx/figurine/figurine-1.0.5-r1.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A vector based graphics editor similar to xfig, but simpler"
HOMEPAGE="http://figurine.sourceforge.net/"
@@ -10,17 +12,13 @@ SRC_URI="mirror://sourceforge/figurine/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=media-gfx/transfig-3.2"
+DEPEND="media-gfx/transfig"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
+ tc-export CC
econf
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README
-}
diff --git a/media-gfx/figurine/files/figurine-1.0.5-fno-common.patch b/media-gfx/figurine/files/figurine-1.0.5-fno-common.patch
new file mode 100644
index 000000000000..362d40b2257a
--- /dev/null
+++ b/media-gfx/figurine/files/figurine-1.0.5-fno-common.patch
@@ -0,0 +1,115 @@
+https://bugs.gentoo.org/707666
+--- a/src/draw.c
++++ b/src/draw.c
+@@ -126,6 +126,8 @@
+ #include "include/figurine.h"
+ #include "include/extern.h"
+
++extern GC whitegc;
++
+ /* redraws a section of a view */
+ /* this should really take a number of disjoint regions */
+ void
+--- a/src/include/extern.h
++++ b/src/include/extern.h
+@@ -285,7 +285,7 @@ extern Pixmap bfills[];
+ extern Pixmap nofill;
+ extern char *filltags[];
+ extern char *fontnames[40][2];
+-int numfontnames;
++extern int numfontnames;
+ extern List afonts;
+
+ extern uint justificationicon_number;
+--- a/src/include/stk_extern.h
++++ b/src/include/stk_extern.h
+@@ -71,8 +71,8 @@ extern GC fontgc;
+ extern GC sfontgc;
+ extern GC colgc;
+ extern Cursor stk_arrow_cursor;
+-XFontStruct *stk_font;
+-XFontStruct *stk_sfont;
++extern XFontStruct *stk_font;
++extern XFontStruct *stk_sfont;
+ extern List stk_window_list;
+ extern stkInternalMenuBar stk_menu_bar;
+ extern stkInternalIconPanel stk_icon_panel;
+--- a/src/init.c
++++ b/src/init.c
+@@ -151,6 +151,8 @@
+ /* xbm's for fillstyle */
+ #include "pixmaps/fillstyles.h"
+
++extern int numfontnames;
++extern GC whitegc;
+
+ static Colormap colourmap;
+ static Visual *visual;
+--- a/src/stk_dialog.c
++++ b/src/stk_dialog.c
+@@ -74,6 +74,9 @@
+
+ static int dial_ticket=0;
+
++extern XFontStruct *stk_sfont;
++extern GC whitegc;
++
+ void free_list(void *);
+ void set_window_cursor(Window, int);
+
+--- a/src/stk_globals.c
++++ b/src/stk_globals.c
+@@ -52,7 +52,7 @@
+ #include "include/stk.h"
+
+ GC topleftgc; /* top & left decoration */
+-GC whitegc; /* white */
++extern GC whitegc; /* white */
+ GC bottomrightgc; /* bottom and right decoration */
+ GC backgroundgc; /* standard GC for STK widget */
+ GC fontgc; /* for drawing the font */
+--- a/src/stk_init.c
++++ b/src/stk_init.c
+@@ -60,6 +60,9 @@
+ extern int screen;
+ extern WindowStruct bar_window;
+
++extern XFontStruct *stk_sfont;
++extern GC whitegc;
++
+ void free_list(void *);
+
+ void
+--- a/src/stk_keyboard.c
++++ b/src/stk_keyboard.c
+@@ -59,6 +59,8 @@
+
+ int str_print(char *str);
+
++extern XFontStruct *stk_font;
++
+ int str_print(char *str)
+ {
+ while (*str!='\0')
+--- a/src/stk_menu.c
++++ b/src/stk_menu.c
+@@ -85,6 +85,8 @@
+
+ void free_list(void *);
+
++extern XFontStruct *stk_font;
++
+ /* create top-level menu bar */
+ int
+ stk_create_menu_bar(WindowStruct window, stkMenuBar *menu)
+--- a/src/stk_util.c
++++ b/src/stk_util.c
+@@ -70,6 +70,8 @@
+
+ extern Atom windelete;
+
++extern XFontStruct *stk_font;
++
+ /* client-side toggle tooltips */
+ void
+ stk_tooltips(Boolean on)