summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-16 18:33:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-16 18:34:37 +0000
commit4c904834a7d46729288f78e0cee06e766c9e4bd2 (patch)
treeb25005df0771746f1fc7d930cc478f21e13da726 /media-gfx/flam3/flam3-3.1.1.ebuild
parentsys-libs/glibc: Remove only unversioned libnsl binaries (diff)
downloadgentoo-4c904834a7d46729288f78e0cee06e766c9e4bd2.tar.gz
gentoo-4c904834a7d46729288f78e0cee06e766c9e4bd2.tar.bz2
gentoo-4c904834a7d46729288f78e0cee06e766c9e4bd2.zip
media-gfx/flam3: Bump #627186
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-gfx/flam3/flam3-3.1.1.ebuild')
-rw-r--r--media-gfx/flam3/flam3-3.1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/flam3/flam3-3.1.1.ebuild b/media-gfx/flam3/flam3-3.1.1.ebuild
new file mode 100644
index 000000000000..fe84e0f3b1cc
--- /dev/null
+++ b/media-gfx/flam3/flam3-3.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Tools and a library for creating flame fractal images"
+HOMEPAGE="http://flam3.com/"
+SRC_URI="https://github.com/scottdraves/flam3/archive/v$PV.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/libxml2
+ media-libs/libpng:=
+ virtual/jpeg:=
+ !<=x11-misc/electricsheep-2.6.8-r2"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.txt )
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ rm -f "${D}"usr/lib*/libflam3.la
+
+ docinto examples
+ dodoc *.flam3
+}