summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-10-20 06:43:57 -0500
committerBen Kohler <bkohler@gentoo.org>2021-10-20 06:44:24 -0500
commitdcd685242816a88734f54ac0e4bf5f750a138761 (patch)
tree50d7dc37672ac86a6733104e4ce5c69e7ebecdef /media-gfx/fotoxx
parentmedia-video/vidify-audiosync: enable python3.10 (diff)
downloadgentoo-dcd685242816a88734f54ac0e4bf5f750a138761.tar.gz
gentoo-dcd685242816a88734f54ac0e4bf5f750a138761.tar.bz2
gentoo-dcd685242816a88734f54ac0e4bf5f750a138761.zip
media-gfx/fotoxx: bump to 21.60
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx/fotoxx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-21.60.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index 091c6a79b194..986f4d559f4d 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -1,2 +1,3 @@
DIST fotoxx-21.50.tar.gz 8693590 BLAKE2B d3bed82c3e856d6ce2433e0357955f32d462d0dfcf8de673a7c0fbe8aeeea766711c2617730c6a83501b07bd5f5ab60c9d56caeacd6ea938428758a39b5a75b3 SHA512 018735ff4b1fc99a64eccb05af05e9858f9dfce3c6925704f1739c22a49d3209f66d668b21cb6030d971bbe116c978c5d491aaba033683d5ed5268ee0e46ff9e
DIST fotoxx-21.55.tar.gz 8667304 BLAKE2B 9a324883ba29d8847763985ff33d3e7eaf2a73449fab9c60dee05144c5dc98caf8bef8ce886736fcfae38a7f58526bfb3868da3d3ae2a283ecfabf1bb8858061 SHA512 a207a861b1bc2d8a41ec36a58b1bc9f61db380ae651dee98faf295a1e98730b7fed5a361ab0f09630d8d0f170e58bdf897424ca1d86f27cb669e75f305ea3fb8
+DIST fotoxx-21.60.tar.gz 8679841 BLAKE2B ec3dcbd0b937d730692e225fec7530ac46390328ae960e8960df7d252bc0cd8630de84bf47dfaf74c1e07855b4b0959e596e5e515ea00a6c430872359b2b4576 SHA512 ac999fcc70acd92c54e85ad276112aaa7f1b7606ea70381d6f833d829fd92c14aacad7a967838e5d28fce80cfa6da8ef05e0ee49b463210cb66a3f8ffc3d22e7
diff --git a/media-gfx/fotoxx/fotoxx-21.60.ebuild b/media-gfx/fotoxx/fotoxx-21.60.ebuild
new file mode 100644
index 000000000000..12a78336fe75
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-21.60.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ media-libs/libchamplain[gtk]
+ virtual/jpeg
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-21.40-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "additional panorama support" media-gfx/hugin
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}