summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-04-02 10:22:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-02 14:57:33 +0200
commit728417f0a8ce57a6daaa448100a101d107c25b6d (patch)
tree3852f1ff2222c9b2ab84a56846d2e43d36f9bf3c /media-gfx/freecad
parentdev-libs/nss: Stabilize 3.68.3 arm64, #836621 (diff)
downloadgentoo-728417f0a8ce57a6daaa448100a101d107c25b6d.tar.gz
gentoo-728417f0a8ce57a6daaa448100a101d107c25b6d.tar.bz2
gentoo-728417f0a8ce57a6daaa448100a101d107c25b6d.zip
media-gfx/freecad: fix build of 0.19.4 with Qt 5.15.3
Backport changes from HEAD FindPySide2Tools.cmake to correctly find the path for uic and rcc binaries. Closes: https://bugs.gentoo.org/836433 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/24861 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/freecad')
-rw-r--r--media-gfx/freecad/files/freecad-0.19.4-backport-correctly-find-PySide2Tools.patch106
-rw-r--r--media-gfx/freecad/freecad-0.19.4.ebuild1
2 files changed, 107 insertions, 0 deletions
diff --git a/media-gfx/freecad/files/freecad-0.19.4-backport-correctly-find-PySide2Tools.patch b/media-gfx/freecad/files/freecad-0.19.4-backport-correctly-find-PySide2Tools.patch
new file mode 100644
index 000000000000..b297727033db
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.19.4-backport-correctly-find-PySide2Tools.patch
@@ -0,0 +1,106 @@
+From https://github.com/FreeCAD/FreeCAD/tree/6b062b25e118fc6d260d8caff6cf46fafd6cfa0f
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 2 Apr 2022 09:30:09 +0200
+Subject: [PATCH] backport correctly find PySide2Tools
+
+Backported from current HEAD
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/cMake/FindPySide2Tools.cmake
++++ b/cMake/FindPySide2Tools.cmake
+@@ -23,7 +23,7 @@ endif(WIN32 OR ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ # Since Qt v5.14, pyside2-uic and pyside2-rcc are directly provided by Qt5Core uic and rcc, with '-g python' option
+ # We test Qt5Core version to act accordingly
+
+-FIND_PACKAGE(Qt5Core)
++FIND_PACKAGE(Qt5 COMPONENTS Core)
+
+ IF(Qt5Core_VERSION VERSION_LESS 5.14)
+ # Legacy (< 5.14)
+@@ -33,13 +33,20 @@ IF(Qt5Core_VERSION VERSION_LESS 5.14)
+ set(RCCOPTIONS "")
+ ELSE(Qt5Core_VERSION VERSION_LESS 5.14)
+ # New (>= 5.14)
+- FIND_PROGRAM(PYSIDE2UICBINARY NAMES uic-qt5 uic pyside2-uic)
+- set(UICOPTIONS "--generator=python")
+- FIND_PROGRAM(PYSIDE2RCCBINARY NAMES rcc-qt5 rcc pyside2-rcc)
+- set(RCCOPTIONS "--generator=python" "--compress-algo=zlib" "--compress=1")
++ if (TARGET Qt::uic)
++ get_property(PYSIDE2UICBINARY TARGET Qt::uic PROPERTY LOCATION)
++ set(UICOPTIONS "--generator=python")
++ endif()
++ if (TARGET Qt::rcc)
++ get_property(PYSIDE2RCCBINARY TARGET Qt::rcc PROPERTY LOCATION)
++ set(RCCOPTIONS "--generator=python" "--compress-algo=zlib" "--compress=1")
++ endif()
+ ENDIF(Qt5Core_VERSION VERSION_LESS 5.14)
+
+ MACRO(PYSIDE_WRAP_UI outfiles)
++ if (NOT PYSIDE2UICBINARY)
++ message(FATAL_ERROR "Qt uic is required for generating ${ARGN}")
++ endif()
+ FOREACH(it ${ARGN})
+ GET_FILENAME_COMPONENT(outfile ${it} NAME_WE)
+ GET_FILENAME_COMPONENT(infile ${it} ABSOLUTE)
+@@ -58,7 +65,7 @@ MACRO(PYSIDE_WRAP_UI outfiles)
+ # we follow the tool command with in-place sed.
+ ADD_CUSTOM_COMMAND(OUTPUT ${outfile}
+ COMMAND "${PYSIDE2UICBINARY}" ${UICOPTIONS} "${infile}" -o "${outfile}"
+- COMMAND sed -i "/^# /d" "${outfile}"
++ COMMAND sed "/^# /d" "${outfile}" >"${outfile}.tmp" && mv "${outfile}.tmp" "${outfile}"
+ MAIN_DEPENDENCY "${infile}"
+ )
+ endif()
+@@ -67,6 +74,9 @@ MACRO(PYSIDE_WRAP_UI outfiles)
+ ENDMACRO (PYSIDE_WRAP_UI)
+
+ MACRO(PYSIDE_WRAP_RC outfiles)
++ if (NOT PYSIDE2RCCBINARY)
++ message(FATAL_ERROR "Qt rcc is required for generating ${ARGN}")
++ endif()
+ FOREACH(it ${ARGN})
+ GET_FILENAME_COMPONENT(outfile ${it} NAME_WE)
+ GET_FILENAME_COMPONENT(infile ${it} ABSOLUTE)
+@@ -85,7 +95,7 @@ MACRO(PYSIDE_WRAP_RC outfiles)
+ # we follow the tool command with in-place sed.
+ ADD_CUSTOM_COMMAND(OUTPUT "${outfile}"
+ COMMAND "${PYSIDE2RCCBINARY}" ${RCCOPTIONS} "${infile}" ${PY_ATTRIBUTE} -o "${outfile}"
+- COMMAND sed -i "/^# /d" "${outfile}"
++ COMMAND sed "/^# /d" "${outfile}" >"${outfile}.tmp" && mv "${outfile}.tmp" "${outfile}"
+ MAIN_DEPENDENCY "${infile}"
+ )
+ endif()
+@@ -93,20 +103,17 @@ MACRO(PYSIDE_WRAP_RC outfiles)
+ ENDFOREACH(it)
+ ENDMACRO (PYSIDE_WRAP_RC)
+
+-IF(EXISTS ${PYSIDE2UICBINARY} AND EXISTS ${PYSIDE2RCCBINARY})
+- set(PYSIDE2_TOOLS_FOUND TRUE)
+-ENDIF(EXISTS ${PYSIDE2UICBINARY} AND EXISTS ${PYSIDE2RCCBINARY})
+-
+ if(PYSIDE2RCCBINARY AND PYSIDE2UICBINARY)
++ set(PYSIDE2_TOOLS_FOUND TRUE)
++ if (NOT PySide2Tools_FIND_QUIETLY)
++ message(STATUS "Found PySide2 tools: ${PYSIDE2UICBINARY}, ${PYSIDE2RCCBINARY}")
++ endif (NOT PySide2Tools_FIND_QUIETLY)
++else(PYSIDE2RCCBINARY AND PYSIDE2UICBINARY)
++ if(PySide2Tools_FIND_REQUIRED)
++ message(FATAL_ERROR "PySide2 tools could not be found, but are required.")
++ else(PySide2Tools_FIND_REQUIRED)
+ if (NOT PySide2Tools_FIND_QUIETLY)
+- message(STATUS "Found PySide2 tools: ${PYSIDE2UICBINARY}, ${PYSIDE2RCCBINARY}")
++ message(STATUS "PySide2 tools: not found.")
+ endif (NOT PySide2Tools_FIND_QUIETLY)
+-else(PYSIDE2RCCBINARY AND PYSIDE2UICBINARY)
+- if(PySide2Tools_FIND_REQUIRED)
+- message(FATAL_ERROR "PySide2 tools could not be found, but are required.")
+- else(PySide2Tools_FIND_REQUIRED)
+- if (NOT PySide2Tools_FIND_QUIETLY)
+- message(STATUS "PySide2 tools: not found.")
+- endif (NOT PySide2Tools_FIND_QUIETLY)
+- endif(PySide2Tools_FIND_REQUIRED)
++ endif(PySide2Tools_FIND_REQUIRED)
+ endif(PYSIDE2RCCBINARY AND PYSIDE2UICBINARY)
+--
+2.35.1
+
diff --git a/media-gfx/freecad/freecad-0.19.4.ebuild b/media-gfx/freecad/freecad-0.19.4.ebuild
index cab7693eaacd..270ba00b2832 100644
--- a/media-gfx/freecad/freecad-0.19.4.ebuild
+++ b/media-gfx/freecad/freecad-0.19.4.ebuild
@@ -125,6 +125,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}"/${P}-Gentoo-specific-don-t-check-vcs.patch
+ "${FILESDIR}"/${P}-backport-correctly-find-PySide2Tools.patch
"${FILESDIR}"/${PN}-0.19.1-0001-Gentoo-specific-Remove-ccache-usage.patch
"${WORKDIR}"/${PN}-0.19.2-0005-Make-smesh-compile-with-vtk9.patch
"${FILESDIR}"/${PN}-0.19.2-0006-add-boost-serialization-to-find_package.patch