summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:13:03 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:16 +0000
commitf4191f199195beda8ef96939b68a00325e04a0f8 (patch)
tree88bee8648b1c24ba2c1d3070012b9c219b1ae47b /media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
parentmedia-gfx/dcraw: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-f4191f199195beda8ef96939b68a00325e04a0f8.tar.gz
gentoo-f4191f199195beda8ef96939b68a00325e04a0f8.tar.bz2
gentoo-f4191f199195beda8ef96939b68a00325e04a0f8.zip
media-gfx/freewrl: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/freewrl/freewrl-3.0.0-r1.ebuild')
-rw-r--r--media-gfx/freewrl/freewrl-3.0.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild b/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
index b7a8547435d6..83573845b926 100644
--- a/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
+++ b/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit autotools nsplugins eutils flag-o-matic java-pkg-opt-2 multilib
+inherit autotools nsplugins eutils flag-o-matic java-pkg-opt-2 multilib toolchain-funcs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -85,8 +85,8 @@ src_configure() {
JAVASCRIPT_ENGINE_LIBS="-ljs"
fi
if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
- JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
- JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
+ JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $($(tc-getPKG_CONFIG) --cflags nspr)"
+ JAVASCRIPT_ENGINE_LIBS="$($(tc-getPKG_CONFIG) --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
fi
export JAVASCRIPT_ENGINE_CFLAGS
export JAVASCRIPT_ENGINE_LIBS