summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/geeqie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/geeqie')
-rw-r--r--media-gfx/geeqie/Manifest1
-rw-r--r--media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch35
-rw-r--r--media-gfx/geeqie/files/geeqie-1.2-fix_version.patch11
-rw-r--r--media-gfx/geeqie/geeqie-1.2-r1.ebuild79
-rw-r--r--media-gfx/geeqie/metadata.xml9
5 files changed, 135 insertions, 0 deletions
diff --git a/media-gfx/geeqie/Manifest b/media-gfx/geeqie/Manifest
new file mode 100644
index 000000000000..8799272ea3cc
--- /dev/null
+++ b/media-gfx/geeqie/Manifest
@@ -0,0 +1 @@
+DIST geeqie-1.2.tar.gz 1904764 SHA256 f13fc2489fb9bed31ed48aec8b2a3a573c11cd6e036f1b07ed2cf6495ccc75dd SHA512 cd27cc480cc649f6ba6ea2997bf9a3dc1aa3f655e6f949de27bb4bbfa79927126851604005bf0a0e2be86683f5b9b06dbfb86b919f828e54a79bafcdd6a0be92 WHIRLPOOL 82e25e743b62566dd99a630fb347966195a93b8eba51a300907e04e7113c5bc39a0bf74da28eeba6325558ff86d1bdea80cfe8c7fedf70ce5466e224e0b648c0
diff --git a/media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch b/media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch
new file mode 100644
index 000000000000..5f13c92cb6db
--- /dev/null
+++ b/media-gfx/geeqie/files/geeqie-1.2-fix-lcms2-integration.patch
@@ -0,0 +1,35 @@
+From a1afabd3ce740872a857234b91eeb64fcf239f6a Mon Sep 17 00:00:00 2001
+From: Klaus Ethgen <Klaus@Ethgen.de>
+Date: Sat, 27 Sep 2014 12:07:10 +0100
+Subject: [PATCH] Fix lcms2 integration
+
+Thanks Michael Schwendt <mschwendt@gmail.com> for the bug reporting and
+the patch.
+---
+ src/color-man.c | 10 ++++++----
+ 1 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/src/color-man.c b/src/color-man.c
+index 7788c7a..e4f1bab 100644
+--- a/src/color-man.c
++++ b/src/color-man.c
+@@ -432,10 +432,12 @@ static gchar *color_man_get_profile_name(ColorManProfileType type, cmsHPROFILE p
+ if (profile)
+ {
+ #ifdef HAVE_LCMS2
+- cmsUInt8Number profileID[17];
+- profileID[16] = '\0';
+- cmsGetHeaderProfileID(profile, profileID);
+- return g_strdup((gchar *) profileID);
++ cmsUInt32Number r;
++ char buffer[20];
++ buffer[0] = '\0';
++ r = cmsGetProfileInfoASCII(profile, cmsInfoDescription, "en", "US", &buffer, 20);
++ buffer[19] = '\0'; /* Just to be sure */
++ return g_strdup(buffer);
+ #else
+ return g_strdup(cmsTakeProductName(profile));
+ #endif
+--
+1.7.1
+
diff --git a/media-gfx/geeqie/files/geeqie-1.2-fix_version.patch b/media-gfx/geeqie/files/geeqie-1.2-fix_version.patch
new file mode 100644
index 000000000000..1d40ea02b2d4
--- /dev/null
+++ b/media-gfx/geeqie/files/geeqie-1.2-fix_version.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2014-10-26 20:33:53.431516625 +0100
++++ configure.in 2014-10-26 20:33:58.790520392 +0100
+@@ -15,7 +15,7 @@
+ dnl GNU General Public License for more details.
+
+ AC_PREREQ(2.57)
+-AC_INIT(geeqie, 1.1, geeqie-devel@lists.sourceforge.net)
++AC_INIT(geeqie, 1.2, geeqie-devel@lists.sourceforge.net)
+
+ # Check for rightly dirs
+ AC_CONFIG_SRCDIR([src/main.c])
diff --git a/media-gfx/geeqie/geeqie-1.2-r1.ebuild b/media-gfx/geeqie/geeqie-1.2-r1.ebuild
new file mode 100644
index 000000000000..95a49039846c
--- /dev/null
+++ b/media-gfx/geeqie/geeqie-1.2-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools base eutils
+
+DESCRIPTION="A lightweight GTK image viewer forked from GQview"
+HOMEPAGE="http://www.geeqie.org"
+# Grab from tag snapshot: http://www.geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc exif jpeg lcms lirc lua tiff xmp"
+
+RDEPEND="x11-libs/gtk+:2
+ virtual/libintl
+ doc? ( app-text/gnome-doc-utils )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ lirc? ( app-misc/lirc )
+ lua? ( >=dev-lang/lua-5.1:= )
+ xmp? ( >=media-gfx/exiv2-0.17:=[xmp] )
+ !xmp? ( exif? ( >=media-gfx/exiv2-0.17 ) )
+ tiff? ( media-libs/tiff:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+S=${WORKDIR}/${PN}-${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-lcms2-integration.patch
+ "${FILESDIR}"/${P}-fix_version.patch
+)
+
+src_prepare() {
+ base_src_prepare
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ # Force disable experimental stuff
+ local myconf="--disable-dependency-tracking
+ --with-readmedir=/usr/share/doc/${PF}
+ --disable-gtk3
+ --disable-clutter
+ --disable-gps
+ $(use_enable jpeg)
+ $(use_enable lcms)
+ $(use_enable lua)
+ $(use_enable lirc)
+ $(use_enable tiff)"
+
+ if use exif || use xmp; then
+ myconf="${myconf} --enable-exiv2"
+ else
+ myconf="${myconf} --disable-exiv2"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}/usr/share/doc/${MY_P}/COPYING"
+}
+
+pkg_postinst() {
+ elog "Some plugins may require additional packages"
+ elog "- Image rotate plugin: media-gfx/fbida (JPEG), media-gfx/imagemagick (TIFF/PNG)"
+ elog "- RAW images plugin: media-gfx/ufraw"
+}
diff --git a/media-gfx/geeqie/metadata.xml b/media-gfx/geeqie/metadata.xml
new file mode 100644
index 000000000000..aed8fe3e0896
--- /dev/null
+++ b/media-gfx/geeqie/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>Geeqie is a lightweight image viewer. It was forked from GQview. The development is focused on features for photo collection maintenance: raw format, Exif/IPTC/XMP metadata and integration with programs like UFraw, ImageMagick, Gimp, gPhoto or ExifTool</longdescription>
+</pkgmetadata>