summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-13 00:29:34 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-13 01:14:59 +0200
commit55f7c734a73f66acbec95e95aecb126b3ef8a809 (patch)
tree4a1de97a28dc7bf6cac2b3cc3b273a9ea9dff7c0 /media-gfx/gnome-photos/gnome-photos-3.24.2.ebuild
parentmedia-gfx/gnome-font-viewer: 3.22.0 → 3.24.0 (diff)
downloadgentoo-55f7c734a73f66acbec95e95aecb126b3ef8a809.tar.gz
gentoo-55f7c734a73f66acbec95e95aecb126b3ef8a809.tar.bz2
gentoo-55f7c734a73f66acbec95e95aecb126b3ef8a809.zip
media-gfx/gnome-photos: version bump 3.22.6 → 3.24.2
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-gfx/gnome-photos/gnome-photos-3.24.2.ebuild')
-rw-r--r--media-gfx/gnome-photos/gnome-photos-3.24.2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/gnome-photos/gnome-photos-3.24.2.ebuild b/media-gfx/gnome-photos/gnome-photos-3.24.2.ebuild
new file mode 100644
index 000000000000..542f1adbcb97
--- /dev/null
+++ b/media-gfx/gnome-photos/gnome-photos-3.24.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="Access, organize and share your photos on GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Photos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flickr test upnp-av"
+
+COMMON_DEPEND="
+ >=app-misc/tracker-1:=[miner-fs]
+ >=dev-libs/glib-2.44:2
+ gnome-base/gnome-desktop:3=
+ >=dev-libs/libgdata-0.15.2:0=[gnome-online-accounts]
+ media-libs/babl
+ >=media-libs/gegl-0.3.14:0.3[cairo,jpeg2k,raw]
+ media-libs/gexiv2
+ >=media-libs/grilo-0.3.0:0.3=
+ >=media-libs/libpng-1.6:0=
+ >=net-libs/gnome-online-accounts-3.8:=
+ >=net-libs/libgfbgraph-0.2.1:0.2
+ sci-geosciences/geocode-glib
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22.10:3
+"
+# gnome-online-miners is also used for google, facebook, DLNA - not only flickr
+# but out of all the grilo-plugins, only upnp-av and flickr get used, which have USE flags here,
+# so don't pull it always, but only if either USE flag is enabled
+RDEPEND="${COMMON_DEPEND}
+ net-misc/gnome-online-miners[flickr?]
+ upnp-av? ( media-plugins/grilo-plugins:0.3[upnp-av] )
+ flickr? ( media-plugins/grilo-plugins:0.3[flickr] )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+ test? ( $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
+"
+
+python_check_deps() {
+ use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # XXX: how to deal with rdtscp support, x86intrin
+ gnome2_src_configure \
+ $(use_enable test dogtail)
+}
+
+src_test() {
+ virtx emake check
+}