summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/greycstoration
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/greycstoration')
-rw-r--r--media-gfx/greycstoration/Manifest1
-rw-r--r--media-gfx/greycstoration/files/greycstoration-2.9-libpng14.patch22
-rw-r--r--media-gfx/greycstoration/greycstoration-2.9-r1.ebuild64
-rw-r--r--media-gfx/greycstoration/metadata.xml11
4 files changed, 98 insertions, 0 deletions
diff --git a/media-gfx/greycstoration/Manifest b/media-gfx/greycstoration/Manifest
new file mode 100644
index 000000000000..6b9abbbd01ed
--- /dev/null
+++ b/media-gfx/greycstoration/Manifest
@@ -0,0 +1 @@
+DIST GREYCstoration-2.9.zip 3639412 SHA256 dfc867bffd38fc204b5fe6a3952d7aa4ac53c2b75aabf45102ed7f6022c1c7be SHA512 f0f90e02087d2670213ed72876105202eab996bb483bed069046c0e01153eb05da91d92f00aa3ed5cc2fecba19f35e20739049c149426453e0e11efd446844ba WHIRLPOOL 667e7411261446d507f26a54d1a95691f81ca878908661ad0c51145a9956b872553b62eeb1937e72fb0d819c97f160af8479c544c9b7b7879afed297daf4f57e
diff --git a/media-gfx/greycstoration/files/greycstoration-2.9-libpng14.patch b/media-gfx/greycstoration/files/greycstoration-2.9-libpng14.patch
new file mode 100644
index 000000000000..e8c0276f8917
--- /dev/null
+++ b/media-gfx/greycstoration/files/greycstoration-2.9-libpng14.patch
@@ -0,0 +1,22 @@
+http://repos.archlinux.org/wsvn/community/greycstoration/trunk/libpng14.patch
+
+--- CImg.h
++++ CImg.h
+@@ -25671,7 +25671,7 @@
+ png_read_info(png_ptr,info_ptr);
+ png_uint_32 W, H;
+ int bit_depth, color_type, interlace_type;
+- png_get_IHDR(png_ptr,info_ptr,&W,&H,&bit_depth,&color_type,&interlace_type,int_p_NULL,int_p_NULL);
++ png_get_IHDR(png_ptr,info_ptr,&W,&H,&bit_depth,&color_type,&interlace_type,NULL,NULL);
+ int new_bit_depth = bit_depth;
+ int new_color_type = color_type;
+
+@@ -25682,7 +25682,7 @@
+ new_bit_depth = 8;
+ }
+ if (new_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8){
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ new_bit_depth = 8;
+ }
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))
diff --git a/media-gfx/greycstoration/greycstoration-2.9-r1.ebuild b/media-gfx/greycstoration/greycstoration-2.9-r1.ebuild
new file mode 100644
index 000000000000..25a0f823bca1
--- /dev/null
+++ b/media-gfx/greycstoration/greycstoration-2.9-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Image regularization algorithm for denoising, inpainting and resizing"
+HOMEPAGE="http://www.greyc.ensicaen.fr/~dtschump/greycstoration/"
+SRC_URI="mirror://sourceforge/cimg/GREYCstoration-${PV}.zip"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fftw imagemagick jpeg lapack png tiff"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ fftw? ( >=sci-libs/fftw-3 )
+ imagemagick? ( media-gfx/imagemagick )
+ jpeg? ( virtual/jpeg )
+ lapack? ( virtual/lapack )
+ png? ( >=media-libs/libpng-1.4 )
+ tiff? ( media-libs/tiff )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ fftw? ( virtual/pkgconfig )
+ lapack? ( virtual/pkgconfig )
+ png? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/GREYCstoration-${PV}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng14.patch
+
+ sed -i \
+ -e "s:../CImg.h:CImg.h:" \
+ greycstoration.cpp || die
+}
+
+src_compile() {
+ local myconf="-Dcimg_use_xshm -Dcimg_use_xrandr -lX11 -lXext -lXrandr"
+
+ use png && myconf+=" -Dcimg_use_png $($(tc-getPKG_CONFIG) --libs libpng) -lz"
+ use jpeg && myconf+=" -Dcimg_use_jpeg -ljpeg"
+ use tiff && myconf+=" -Dcimg_use_tiff -ltiff"
+ use imagemagick && \
+ myconf+=" -Dcimg_use_magick $(Magick++-config --cppflags) $(Magick++-config --libs)"
+ use fftw && myconf+=" -Dcimg_use_fftw3 $($(tc-getPKG_CONFIG) --libs fftw3)"
+ use lapack && myconf+=" -Dcimg_use_lapack $($(tc-getPKG_CONFIG) --libs lapack)"
+
+ _cmd="$(tc-getCXX) ${LDFLAGS} ${CXXFLAGS} -fno-tree-pre \
+ -o greycstoration greycstoration.cpp \
+ ${myconf} -lm -lpthread"
+ einfo "${_cmd}"
+ eval ${_cmd} || die
+}
+
+src_install() {
+ dobin greycstoration
+}
diff --git a/media-gfx/greycstoration/metadata.xml b/media-gfx/greycstoration/metadata.xml
new file mode 100644
index 000000000000..31b8fca48b10
--- /dev/null
+++ b/media-gfx/greycstoration/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cimg</remote-id>
+ </upstream>
+</pkgmetadata>