summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gthumb/gthumb-3.4.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gthumb/gthumb-3.4.0.ebuild')
-rw-r--r--media-gfx/gthumb/gthumb-3.4.0.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/media-gfx/gthumb/gthumb-3.4.0.ebuild b/media-gfx/gthumb/gthumb-3.4.0.ebuild
new file mode 100644
index 000000000000..ead252ef0e15
--- /dev/null
+++ b/media-gfx/gthumb/gthumb-3.4.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Image viewer and browser for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/gthumb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cdr exif gnome-keyring gstreamer http jpeg json lcms raw slideshow svg tiff test webkit webp"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.36.0:2[dbus]
+ >=x11-libs/gtk+-3.10.0:3
+
+ media-libs/libpng:0=
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+
+ cdr? ( >=app-cdr/brasero-3.2 )
+ exif? ( >=media-gfx/exiv2-0.21:= )
+ gnome-keyring? ( >=app-crypt/libsecret-0.11 )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ http? ( >=net-libs/libsoup-2.42.0:2.4 )
+ jpeg? ( virtual/jpeg:0= )
+ json? ( >=dev-libs/json-glib-0.15.0 )
+ lcms? ( >=media-libs/lcms-2.6:2 )
+ slideshow? (
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1:1.0 )
+ svg? ( >=gnome-base/librsvg-2.34 )
+ tiff? ( media-libs/tiff:= )
+ raw? ( >=media-libs/libraw-0.14:= )
+ !raw? ( media-gfx/dcraw )
+ webkit? ( net-libs/webkit-gtk:4 )
+ webp? ( >=media-libs/libwebp-0.2.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-0.1.4
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+src_prepare() {
+ # Remove unwanted CFLAGS added with USE=debug
+ sed -e 's/CFLAGS="$CFLAGS -g -O0 -DDEBUG"//' \
+ -i configure.ac -i configure || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Upstream says in configure help that libchamplain support
+ # crashes frequently
+ gnome2_src_configure \
+ --disable-static \
+ --disable-libchamplain \
+ $(use_enable cdr libbrasero) \
+ $(use_enable exif exiv2) \
+ $(use_enable gnome-keyring libsecret) \
+ $(use_enable gstreamer) \
+ $(use_enable http libsoup) \
+ $(use_enable jpeg) \
+ $(use_enable json libjson-glib) \
+ $(use_enable lcms lcms2) \
+ $(use_enable raw libraw) \
+ $(use_enable slideshow clutter) \
+ $(use_enable svg librsvg) \
+ $(use_enable test test-suite) \
+ $(use_enable tiff) \
+ $(use_enable webkit webkit2) \
+ $(use_enable webp libwebp)
+}