summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-09 13:45:00 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-09 13:45:00 +0200
commit63c2feb7f522e0615263d2a6d7ffe1b497bf7698 (patch)
treef030411be575ba509a551d1f6a3e47e66d465119 /media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
parentmedia-libs/openimageio: Support python 3.5, fix giflib dep (diff)
downloadgentoo-63c2feb7f522e0615263d2a6d7ffe1b497bf7698.tar.gz
gentoo-63c2feb7f522e0615263d2a6d7ffe1b497bf7698.tar.bz2
gentoo-63c2feb7f522e0615263d2a6d7ffe1b497bf7698.zip
media-gfx/gtkimageview: tests are severely broken and not meant to be run (#483952), stop relying on userpriv (#516580), update eapi, don't rebuild gtk-doc.
Package-Manager: portage-2.3.1
Diffstat (limited to 'media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild')
-rw-r--r--media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild51
1 files changed, 14 insertions, 37 deletions
diff --git a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
index 19d3b30f9130..77eebb35e413 100644
--- a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
+++ b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-
+EAPI=6
GNOME2_LA_PUNT="yes"
-VIRTUALX_REQUIRED=test
-inherit autotools gnome2 virtualx
+inherit autotools gnome2
DESCRIPTION="A simple image viewer widget for GTK"
HOMEPAGE="https://projects.gnome.org/gtkimageview/"
@@ -16,57 +14,36 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE="doc examples static-libs"
+IUSE="examples static-libs"
-# tests do not work with userpriv
-RESTRICT="test? ( userpriv )"
+# tests are severely broken, bug #483952
+RESTRICT="test"
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
gnome-base/gnome-common
dev-util/gtk-doc-am
- doc? ( >=dev-util/gtk-doc-1.8 )"
-
-pkg_setup() {
- DOCS="README"
- G2CONF="$(use_enable static-libs static)"
-}
+"
src_prepare() {
gnome2_src_prepare
# Prevent excessive build failures due to gcc changes
- sed -e '/CFLAGS/s/-Werror //g' -i configure.in || die "sed 1 failed"
-
- # Prevent excessive build failures due to glib/gtk changes
- sed '/DEPRECATED_FLAGS/d' -i configure.in || die "sed 2 failed"
+ sed -e '/CFLAGS/s/-Werror //g' -i configure.in || die
# Gold linker fix
sed -e '/libtest.la/s:$: -lm:g' -i tests/Makefile.am || die
- if use doc; then
- sed "/^TARGET_DIR/i \GTKDOC_REBASE=${EPREFIX}/usr/bin/gtkdoc-rebase" \
- -i gtk-doc.make || die "sed 3 failed"
- else
- sed "/^TARGET_DIR/i \GTKDOC_REBASE=true" \
- -i gtk-doc.make || die "sed 4 failed"
- fi
+ # Don't rebuild gtk-doc
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=true" -i gtk-doc.make || die
+ mv configure.in configure.ac || die
AT_NOELIBTOOLIZE=yes eautoreconf
}
-src_test() {
- # the tests are only built, but not run by default
- local failed="0"
- Xemake check
- cd "${S}"/tests
- for test in ./test-* ; do
- if [[ -x ${test} ]] ; then
- VIRTUALX_COMMAND="${test}"
- virtualmake || failed=$((${failed}+1))
- fi
- done
- [[ ${failed} -gt 0 ]] && die "${failed} tests failed"
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable static-libs static)
}
src_install() {