summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-04-25 23:22:56 +0300
committerIan Delaney <idella4@gentoo.org>2016-04-26 16:49:42 +0800
commitd5899b9bb592b3939914c6600c6f3865c224e035 (patch)
tree7de6e6e84130fdcf30af35f2b28fff1c8ce054b7 /media-gfx/imv/imv-9999.ebuild
parentnet-firewall/shorewall: Bump to v5.0.8 (diff)
downloadgentoo-d5899b9bb592b3939914c6600c6f3865c224e035.tar.gz
gentoo-d5899b9bb592b3939914c6600c6f3865c224e035.tar.bz2
gentoo-d5899b9bb592b3939914c6600c6f3865c224e035.zip
media-gfx/imv: new ebuild
initial versions: 2.0.0, live Closes: https://github.com/gentoo/gentoo/pull/1351 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'media-gfx/imv/imv-9999.ebuild')
-rw-r--r--media-gfx/imv/imv-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/imv/imv-9999.ebuild b/media-gfx/imv/imv-9999.ebuild
new file mode 100644
index 000000000000..68c6bd76918b
--- /dev/null
+++ b/media-gfx/imv/imv-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils fdo-mime git-r3
+
+DESCRIPTION="Minimal image viewer designed for tiling window manager users"
+HOMEPAGE="https://github.com/eXeC64/imv"
+EGIT_REPO_URI="https://github.com/eXeC64/imv.git"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/libsdl2
+ media-libs/sdl2-ttf
+ media-libs/freeimage
+"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}