summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-11 10:20:34 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-11 10:20:48 +0100
commit8f7e9907cbdc7b5b2a620ed93b092693de1cf43c (patch)
tree2f6f7ee5c574d6b6e478384ee2bb9250d01c4425 /media-gfx/inkscape/files
parentdev-libs/libgit2: Bump to 0.28.4 (diff)
downloadgentoo-8f7e9907cbdc7b5b2a620ed93b092693de1cf43c.tar.gz
gentoo-8f7e9907cbdc7b5b2a620ed93b092693de1cf43c.tar.bz2
gentoo-8f7e9907cbdc7b5b2a620ed93b092693de1cf43c.zip
media-gfx/inkscape-1.0_beta2: bump
removed patches that are already applied by upstream Bug: https://bugs.gentoo.org/696794 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape/files')
-rw-r--r--media-gfx/inkscape/files/inkscape-1.0_beta1-avoid-reordering-cmake-cxx-flags.patch130
-rw-r--r--media-gfx/inkscape/files/inkscape-1.0_beta1-poppler-0.82.patch70
2 files changed, 0 insertions, 200 deletions
diff --git a/media-gfx/inkscape/files/inkscape-1.0_beta1-avoid-reordering-cmake-cxx-flags.patch b/media-gfx/inkscape/files/inkscape-1.0_beta1-avoid-reordering-cmake-cxx-flags.patch
deleted file mode 100644
index bd78bc582325..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.0_beta1-avoid-reordering-cmake-cxx-flags.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-From 09319f688e10d47f9fc9be2b6feb831fb132660a Mon Sep 17 00:00:00 2001
-From: Patrick Storz <eduard.braun2@gmx.de>
-Date: Sat, 12 Oct 2019 15:56:14 +0200
-Subject: [PATCH] CMake: Avoid reordering CMAKE_CXX_FLAGS
-
-Order matters; the reordering caused the _FORTIFY_SOURCE flag to be
-always undefined (as we flipped a "-U" and "-D")
-
-Also skip removing duplicates to avoid similar pitfalls (we kept
-only the first occurrence but should've kept the last)
-It did not work properly anyway (we still had duplicates in the end)
-and was only required as we wrote the final CMAKE_CXX_FLAGS back to
-cache and consequently appended new flags with every run of CMAKE.
----
- CMakeLists.txt | 13 -----------
- CMakeScripts/CanonicalizeFlagsVar.cmake | 11 ----------
- CMakeScripts/DefineDependsandFlags.cmake | 28 ++++++++++++++----------
- 3 files changed, 17 insertions(+), 35 deletions(-)
- delete mode 100644 CMakeScripts/CanonicalizeFlagsVar.cmake
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b30f013f38..aa14e13e01 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -207,19 +207,6 @@ if(GMOCK_PRESENT)
- endif()
- endif()
-
--# -----------------------------------------------------------------------------
--# Canonicalize the flags to speed up recompilation using ccache/etc.
--# This should be the last thing we do:
--# -----------------------------------------------------------------------------
--include(CMakeScripts/CanonicalizeFlagsVar.cmake)
--canonicalize_flags_var("${CMAKE_CXX_FLAGS}" _new_cxx)
--set(CMAKE_CXX_FLAGS "${_new_cxx}" CACHE STRING "" FORCE)
--canonicalize_flags_var("${CMAKE_CXX_FLAGS_DEBUG}" _new_cxx)
--set(CMAKE_CXX_FLAGS_DEBUG "${_new_cxx}" CACHE STRING "" FORCE)
--# message(FATAL_ERROR "CMAKE_CXX_FLAGS = <${CMAKE_CXX_FLAGS}>")
--
--
--
-
- # -----------------------------------------------------------------------------
- # Clean Targets
-diff --git a/CMakeScripts/CanonicalizeFlagsVar.cmake b/CMakeScripts/CanonicalizeFlagsVar.cmake
-deleted file mode 100644
-index ddc5b7b5d3..0000000000
---- a/CMakeScripts/CanonicalizeFlagsVar.cmake
-+++ /dev/null
-@@ -1,11 +0,0 @@
--# This file is copyright by Shlomi Fish, 2016.
--#
--# This file is licensed under the MIT/X11 license:
--# https://opensource.org/licenses/mit-license.php
--
--macro (canonicalize_flags_var in_val out_var)
-- string(REPLACE " " ";" _c "${in_val}")
-- list(REMOVE_DUPLICATES _c)
-- list(SORT _c)
-- string(REPLACE ";" " " "${out_var}" "${_c}")
--endmacro()
-diff --git a/CMakeScripts/DefineDependsandFlags.cmake b/CMakeScripts/DefineDependsandFlags.cmake
-index 996100b4d7..9dd7f7785f 100644
---- a/CMakeScripts/DefineDependsandFlags.cmake
-+++ b/CMakeScripts/DefineDependsandFlags.cmake
-@@ -2,6 +2,7 @@ set(INKSCAPE_LIBS "")
- set(INKSCAPE_INCS "")
- set(INKSCAPE_INCS_SYS "")
- set(INKSCAPE_CXX_FLAGS "")
-+set(INKSCAPE_CXX_FLAGS_DEBUG "")
-
- list(APPEND INKSCAPE_INCS ${PROJECT_SOURCE_DIR}
- ${PROJECT_SOURCE_DIR}/src
-@@ -98,7 +99,7 @@ list(APPEND INKSCAPE_INCS_SYS ${INKSCAPE_DEP_INCLUDE_DIRS})
- add_definitions(${INKSCAPE_DEP_CFLAGS_OTHER})
-
- find_package(DoubleConversion REQUIRED) # lib2geom dependency
--
-+
- if(WITH_JEMALLOC)
- find_package(JeMalloc)
- if (JEMALLOC_FOUND)
-@@ -369,14 +370,6 @@ sanitize_ldflags_for_libs(SIGC++_LDFLAGS)
- list(APPEND INKSCAPE_LIBS ${SIGC++_LDFLAGS})
- list(APPEND INKSCAPE_CXX_FLAGS ${SIGC++_CFLAGS_OTHER})
-
--list(REMOVE_DUPLICATES INKSCAPE_CXX_FLAGS)
--foreach(flag ${INKSCAPE_CXX_FLAGS})
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${flag}" CACHE STRING "" FORCE)
--endforeach()
--foreach(flag ${INKSCAPE_CXX_FLAGS_DEBUG})
-- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} ${flag}" CACHE STRING "" FORCE)
--endforeach()
--
- # Some linkers, like gold, don't find symbols recursively. So we have to link against X11 explicitly
- find_package(X11)
- if(X11_FOUND)
-@@ -386,14 +379,27 @@ endif(X11_FOUND)
-
- # end Dependencies
-
-+
-+
-+# Set include directories and CXX flags
-+# (INKSCAPE_LIBS are set as target_link_libraries for inkscape_base in src/CMakeLists.txt)
-+
-+foreach(flag ${INKSCAPE_CXX_FLAGS})
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${flag}")
-+endforeach()
-+foreach(flag ${INKSCAPE_CXX_FLAGS_DEBUG})
-+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} ${flag}")
-+endforeach()
-+
- list(REMOVE_DUPLICATES INKSCAPE_LIBS)
- list(REMOVE_DUPLICATES INKSCAPE_INCS_SYS)
-
--# C/C++ Flags
- include_directories(${INKSCAPE_INCS})
- include_directories(SYSTEM ${INKSCAPE_INCS_SYS})
-
--include(${CMAKE_CURRENT_LIST_DIR}/ConfigChecks.cmake)
-+include(${CMAKE_CURRENT_LIST_DIR}/ConfigChecks.cmake) # TODO: Check if this needs to be "hidden" here
-
- unset(INKSCAPE_INCS)
- unset(INKSCAPE_INCS_SYS)
-+unset(INKSCAPE_CXX_FLAGS)
-+unset(INKSCAPE_CXX_FLAGS_DEBUG)
---
-2.22.0
-
diff --git a/media-gfx/inkscape/files/inkscape-1.0_beta1-poppler-0.82.patch b/media-gfx/inkscape/files/inkscape-1.0_beta1-poppler-0.82.patch
deleted file mode 100644
index 4c5bff4977a6..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.0_beta1-poppler-0.82.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 324c7903d9fd62e74c042c31477299be3b980fd2 Mon Sep 17 00:00:00 2001
-From: Thomas Holder <thomas@thomas-holder.de>
-Date: Sat, 26 Oct 2019 14:39:31 +0200
-Subject: [PATCH] fix poppler 0.82.0 build
-
----
- src/extension/internal/pdfinput/pdf-parser.cpp | 2 +-
- src/extension/internal/pdfinput/poppler-transition-api.h | 6 ++++++
- src/extension/internal/pdfinput/svg-builder.cpp | 2 +-
- src/extension/internal/pdfinput/svg-builder.h | 2 +-
- 4 files changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
-index 4f798e35bf..4eae275757 100644
---- a/src/extension/internal/pdfinput/pdf-parser.cpp
-+++ b/src/extension/internal/pdfinput/pdf-parser.cpp
-@@ -2405,7 +2405,7 @@ void PdfParser::doShowText(GooString *s) {
- int wMode;
- double riseX, riseY;
- CharCode code;
-- Unicode *u = nullptr;
-+ Unicode _POPPLER_CONST_82 *u = nullptr;
- double x, y, dx, dy, tdx, tdy;
- double originX, originY, tOriginX, tOriginY;
- double oldCTM[6], newCTM[6];
-diff --git a/src/extension/internal/pdfinput/poppler-transition-api.h b/src/extension/internal/pdfinput/poppler-transition-api.h
-index 5e8bc4ae90..01834007e8 100644
---- a/src/extension/internal/pdfinput/poppler-transition-api.h
-+++ b/src/extension/internal/pdfinput/poppler-transition-api.h
-@@ -14,6 +14,12 @@
-
- #include <glib/poppler-features.h>
-
-+#if POPPLER_CHECK_VERSION(0, 82, 0)
-+#define _POPPLER_CONST_82 const
-+#else
-+#define _POPPLER_CONST_82
-+#endif
-+
- #if POPPLER_CHECK_VERSION(0, 76, 0)
- #define _POPPLER_NEW_PARSER(xref, obj) Parser(xref, obj, gFalse)
- #else
-diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
-index 14727eba5f..a7134684a0 100644
---- a/src/extension/internal/pdfinput/svg-builder.cpp
-+++ b/src/extension/internal/pdfinput/svg-builder.cpp
-@@ -1395,7 +1395,7 @@ void SvgBuilder::beginString(GfxState *state) {
- void SvgBuilder::addChar(GfxState *state, double x, double y,
- double dx, double dy,
- double originX, double originY,
-- CharCode /*code*/, int /*nBytes*/, Unicode *u, int uLen) {
-+ CharCode /*code*/, int /*nBytes*/, Unicode const *u, int uLen) {
-
-
- bool is_space = ( uLen == 1 && u[0] == 32 );
-diff --git a/src/extension/internal/pdfinput/svg-builder.h b/src/extension/internal/pdfinput/svg-builder.h
-index c42d694dec..050465d4bf 100644
---- a/src/extension/internal/pdfinput/svg-builder.h
-+++ b/src/extension/internal/pdfinput/svg-builder.h
-@@ -142,7 +142,7 @@ public:
- void addChar(GfxState *state, double x, double y,
- double dx, double dy,
- double originX, double originY,
-- CharCode code, int nBytes, Unicode *u, int uLen);
-+ CharCode code, int nBytes, Unicode const *u, int uLen);
- void beginTextObject(GfxState *state);
- void endTextObject(GfxState *state);
-
---
-2.22.0