summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-24 21:33:07 +0000
committerSam James <sam@gentoo.org>2020-10-25 19:11:48 +0000
commit9c8633de85e5ade3b086b6b58c8bfce7df2754e5 (patch)
treea5c143a58f835d1ebc2a733fa4f980603cacb8b5 /media-gfx/iscan-plugin-gt-f500
parentmedia-gfx/iscan-plugin-gt-f720: port to EAPI 7 (diff)
downloadgentoo-9c8633de85e5ade3b086b6b58c8bfce7df2754e5.tar.gz
gentoo-9c8633de85e5ade3b086b6b58c8bfce7df2754e5.tar.bz2
gentoo-9c8633de85e5ade3b086b6b58c8bfce7df2754e5.zip
media-gfx/iscan-plugin-gt-f500: port to EAPI 7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f500')
-rw-r--r--media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild45
1 files changed, 15 insertions, 30 deletions
diff --git a/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
index ec4ff46f4fda..dc9d71820484 100644
--- a/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
+++ b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
@@ -1,27 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit multilib rpm versionator
+inherit rpm
-MY_P="${PN}-$(replace_version_separator 3 -)"
+MY_P="${PN}-$(ver_rs 3 -)"
DESCRIPTION="Epson Perfection 2480/2580 PHOTO scanner plugin for SANE 'epkowa' backend"
HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
SRC_URI="https://dev.gentoo.org/~flameeyes/avasys/${MY_P}.c2.i386.rpm"
+S="${WORKDIR}"
LICENSE="EPSON EAPL"
SLOT="0"
KEYWORDS="-* ~amd64"
-
IUSE="minimal"
DEPEND="minimal? ( >=media-gfx/iscan-2.21.0 )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
-
src_configure() { :; }
src_compile() { :; }
@@ -38,47 +36,34 @@ src_install() {
doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
}
-pkg_setup() {
- basecmds=(
- "iscan-registry --COMMAND interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
- )
-}
-
pkg_postinst() {
elog
elog "Firmware file esfw41.bin for Epson Perfection 2480/2580 PHOTO"
- elog "has been installed in /usr/share/iscan."
+ elog "has been installed in ${EROOT}/usr/share/iscan."
elog
+
use minimal && return
- [[ -n ${REPLACING_VERSIONS} ]] && return
+ [[ -n "${REPLACING_VERSIONS}" ]] && return
# Needed for scanner to work properly.
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/add}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --add interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin' || die
else
ewarn "Unable to register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/add}"
- done
+ ewarn "iscan-registry --add interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
fi
}
pkg_prerm() {
use minimal && return
- [[ -n ${REPLACED_BY_VERSION} ]] && return
+ [[ -n "${REPLACED_BY_VERSION}" ]] && return
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/remove}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --remove interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin' || die
else
ewarn "Unable to de-register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/remove}"
- done
+ ewarn "iscan-registry --remove interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
fi
}