summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/jpeg2ps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/jpeg2ps')
-rw-r--r--media-gfx/jpeg2ps/Manifest1
-rw-r--r--media-gfx/jpeg2ps/files/jpeg2ps-1.9-include.diff11
-rw-r--r--media-gfx/jpeg2ps/jpeg2ps-1.9-r1.ebuild52
-rw-r--r--media-gfx/jpeg2ps/metadata.xml10
4 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/jpeg2ps/Manifest b/media-gfx/jpeg2ps/Manifest
new file mode 100644
index 000000000000..561ca8228c00
--- /dev/null
+++ b/media-gfx/jpeg2ps/Manifest
@@ -0,0 +1 @@
+DIST jpeg2ps-1.9.tar.gz 67105 RMD160 076c59aeded1615bdb65db138a8448e9146f7ed3 SHA1 2fc2701c7c00ba17b051ebcc7b9c8059eb6614f9 SHA256 e09919ff55bb1fd26299adfe92e5ea0e7daaa3bfa0277a0483cac9764eac25a2
diff --git a/media-gfx/jpeg2ps/files/jpeg2ps-1.9-include.diff b/media-gfx/jpeg2ps/files/jpeg2ps-1.9-include.diff
new file mode 100644
index 000000000000..f07b69c5bc6a
--- /dev/null
+++ b/media-gfx/jpeg2ps/files/jpeg2ps-1.9-include.diff
@@ -0,0 +1,11 @@
+diff --exclude='*~' -Naur jpeg2ps-1.9.orig/asc85ec.c jpeg2ps-1.9/asc85ec.c
+--- jpeg2ps-1.9.orig/asc85ec.c 2005-09-10 23:02:15.000000000 -0300
++++ jpeg2ps-1.9/asc85ec.c 2005-09-10 23:08:08.000000000 -0300
+@@ -3,6 +3,7 @@
+
+ #include <stdio.h>
+ #include <fcntl.h>
++#include <stdlib.h>
+
+ /* try to identify Mac compilers */
+ #ifdef __MWERKS__
diff --git a/media-gfx/jpeg2ps/jpeg2ps-1.9-r1.ebuild b/media-gfx/jpeg2ps/jpeg2ps-1.9-r1.ebuild
new file mode 100644
index 000000000000..08f37b3c2e22
--- /dev/null
+++ b/media-gfx/jpeg2ps/jpeg2ps-1.9-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts JPEG images to Postscript using a wrapper"
+HOMEPAGE="http://www.pdflib.com/download/free-software/jpeg2ps/"
+SRC_URI="http://www.pdflib.com/products/more/jpeg2ps/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="metric"
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ #bug 105561
+ epatch "${FILESDIR}"/${P}-include.diff
+}
+
+src_compile() {
+ pagesize=""
+ use metric && pagesize="-DA4"
+ emake CFLAGS="-c ${CFLAGS} ${pagesize}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ # The Makefile is hard-coded to install to /usr/local/ so we
+ # simply copy the files manually
+ dobin jpeg2ps || die "dobin failed"
+ doman jpeg2ps.1 || die "doman failed"
+ dodoc jpeg2ps.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ if [ -z ${pagesize} ]; then
+ elog "By default, this installation of jpeg2ps will generate"
+ elog "letter size output. You can force A4 output with"
+ elog " jpeg2ps -p a4 file.jpg > file.ps"
+ else
+ elog "By default, this installation of jpeg2ps will generate"
+ elog "A4 size output. You can force letter output with"
+ elog " jpeg2ps -p letter file.jpg > file.ps"
+ fi
+ elog
+}
diff --git a/media-gfx/jpeg2ps/metadata.xml b/media-gfx/jpeg2ps/metadata.xml
new file mode 100644
index 000000000000..19f4dfa8ed88
--- /dev/null
+++ b/media-gfx/jpeg2ps/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+<use>
+ <flag name='metric'>
+ Default to A4 paper size
+ </flag>
+</use>
+</pkgmetadata>