summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/jpegtoavi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/jpegtoavi')
-rw-r--r--media-gfx/jpegtoavi/Manifest1
-rw-r--r--media-gfx/jpegtoavi/files/jpegtoavi-1.5-Makefile.patch31
-rw-r--r--media-gfx/jpegtoavi/jpegtoavi-1.5.ebuild30
-rw-r--r--media-gfx/jpegtoavi/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/jpegtoavi/Manifest b/media-gfx/jpegtoavi/Manifest
new file mode 100644
index 000000000000..401c724c169c
--- /dev/null
+++ b/media-gfx/jpegtoavi/Manifest
@@ -0,0 +1 @@
+DIST jpegtoavi-1.5.tar.gz 14882 SHA256 6ddedb9a82d5a4b4b57bac2750a73c59584d38adad98b199e485c6c99328fc93
diff --git a/media-gfx/jpegtoavi/files/jpegtoavi-1.5-Makefile.patch b/media-gfx/jpegtoavi/files/jpegtoavi-1.5-Makefile.patch
new file mode 100644
index 000000000000..9f562f293b31
--- /dev/null
+++ b/media-gfx/jpegtoavi/files/jpegtoavi-1.5-Makefile.patch
@@ -0,0 +1,31 @@
+--- Makefile.orig 2010-03-02 23:06:07.000000000 +0200
++++ Makefile 2010-03-02 23:11:59.000000000 +0200
+@@ -1,4 +1,4 @@
+-CC=gcc
++CC ?= gcc
+ INCLUDE=
+ LIBS=-L.
+ SOURCES=jpegtoavi.c avifmt.h byteswap.h llist.h llist.c
+@@ -10,7 +10,8 @@
+ PACKAGE_VERSION_MIN=5
+ PACKAGE_VERSION=$(PACKAGE_VERSION_MAJ).$(PACKAGE_VERSION_MIN)
+ VERBOSE=0
+-CCFLAGS=$(INCLUDE) -O3 -Wall -ansi -g -DLINUX -D__UNIX__ \
++CFLAGS += -Wall -ansi
++CPPFLAGS += $(INCLUDE) -DLINUX -D__UNIX__ \
+ -DVERSION_MIN=$(PACKAGE_VERSION_MIN) \
+ -DVERSION_MAJ=$(PACKAGE_VERSION_MAJ) \
+ -DVERBOSE=$(VERBOSE)
+@@ -27,10 +28,10 @@
+ all: jpegtoavi
+
+ %.o: %.c
+- $(CC) $(CCFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ jpegtoavi: jpegtoavi.o llist.o
+- $(CC) $(CCFLAGS) jpegtoavi.o llist.o $(LIBS) -o $@
++ $(CC) $(LDFLAGS) jpegtoavi.o llist.o $(LIBS) -o $@
+
+ distdir: $(DISTFILES)
+ $(am__remove_distdir)
diff --git a/media-gfx/jpegtoavi/jpegtoavi-1.5.ebuild b/media-gfx/jpegtoavi/jpegtoavi-1.5.ebuild
new file mode 100644
index 000000000000..105845b2ea4a
--- /dev/null
+++ b/media-gfx/jpegtoavi/jpegtoavi-1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="JPEG to AVI/MJPEG animation command-line conversion tool"
+HOMEPAGE="http://sourceforge.net/projects/jpegtoavi/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1
+ dodoc CHANGELOG README
+}
diff --git a/media-gfx/jpegtoavi/metadata.xml b/media-gfx/jpegtoavi/metadata.xml
new file mode 100644
index 000000000000..69de869b54a4
--- /dev/null
+++ b/media-gfx/jpegtoavi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">jpegtoavi</remote-id>
+ </upstream>
+</pkgmetadata>