summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/mypaint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/Manifest2
-rw-r--r--media-gfx/mypaint/files/mypaint-0.9.0-gentoo.patch26
-rw-r--r--media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch25
-rw-r--r--media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch53
-rw-r--r--media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch24
-rw-r--r--media-gfx/mypaint/files/mypaint-1.1.0-gentoo.patch36
-rw-r--r--media-gfx/mypaint/files/mypaint-1.1.0-json-c-0.11.patch15
-rw-r--r--media-gfx/mypaint/metadata.xml11
-rw-r--r--media-gfx/mypaint/mypaint-1.0.0-r1.ebuild75
-rw-r--r--media-gfx/mypaint/mypaint-1.1.0-r1.ebuild88
-rw-r--r--media-gfx/mypaint/mypaint-1.1.0-r2.ebuild89
-rw-r--r--media-gfx/mypaint/mypaint-1.1.0.ebuild81
12 files changed, 525 insertions, 0 deletions
diff --git a/media-gfx/mypaint/Manifest b/media-gfx/mypaint/Manifest
new file mode 100644
index 000000000000..eae8bb3f3e0b
--- /dev/null
+++ b/media-gfx/mypaint/Manifest
@@ -0,0 +1,2 @@
+DIST mypaint-1.0.0.tar.bz2 36748957 SHA256 ced440ec0307e29bfe4f612604fe27ec9bfaea3f4f9c8019ffaa50ef12dc7131 SHA512 91434f6d352d4f5dde3d919772a678a17f15a6d2914fb2377b40e4a0fea042e3c96b5618e1864eacdbfa52f449be03062da2ecb8ec08bae168e3a12904047bf2 WHIRLPOOL a4693b6436485126a033dacb014586e85c448863bbb14acb30aff739a96d8d2abdd2c920ad3e9a5be7790d18e13e4a8e15ebcde85fafcaafe9d2a901b53d5f52
+DIST mypaint-1.1.0.tar.bz2 37416388 SHA256 780d57e50dd90afd586873bc5120261930ea4c309d4d0958020916932122e838 SHA512 a3eef378ddcaa0a33f9afc49cc587489ecfff6f3e46e2238aab83f89d682f2407e2760e6029eaac3591f0a8955c95280c12839adcb42ec452cefbcdb142ab9b9 WHIRLPOOL bfd7356ad393dd85b91ccc010b5d0be23a6d82a33866edade0ef6eb739a1cbdb6823d7bffbdc943f96cdac9059abb7ac1edacf31d4ac2cd3871444594e23557a
diff --git a/media-gfx/mypaint/files/mypaint-0.9.0-gentoo.patch b/media-gfx/mypaint/files/mypaint-0.9.0-gentoo.patch
new file mode 100644
index 000000000000..329c8a981e6f
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-0.9.0-gentoo.patch
@@ -0,0 +1,26 @@
+Index: mypaint-0.9.0/SConstruct
+===================================================================
+--- mypaint-0.9.0.orig/SConstruct
++++ mypaint-0.9.0/SConstruct
+@@ -64,6 +64,21 @@ if env['debug']:
+ env.Append(CPPDEFINES='HEAVY_DEBUG')
+ env.Append(CCFLAGS='-O0', LINKFLAGS='-O0')
+
++# Respect cxxflags,ldflags and cxx
++# Code found on
++# http://http://dev.gentoo.org/~vapier/scons-blows.txt
++import SCons.Util
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++
+ Export('env')
+ module = SConscript('lib/SConscript')
+ SConscript('brushlib/SConscript')
diff --git a/media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch b/media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch
new file mode 100644
index 000000000000..9c0f884d752a
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch
@@ -0,0 +1,25 @@
+Index: mypaint-0.9.1/SConstruct
+===================================================================
+--- mypaint-0.9.1.orig/SConstruct
++++ mypaint-0.9.1/SConstruct
+@@ -70,6 +70,20 @@ if env.get('CPPDEFINES'):
+ if env['debug']:
+ env.Append(CPPDEFINES='HEAVY_DEBUG')
+ env.Append(CCFLAGS='-O0', LINKFLAGS='-O0')
++# Respect cxxflags,ldflags and cxx
++# Code found on
++# http://http://dev.gentoo.org/~vapier/scons-blows.txt
++import SCons.Util
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ Export('env', 'python')
+ module = SConscript('lib/SConscript')
diff --git a/media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch b/media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch
new file mode 100644
index 000000000000..7d7ac3e36359
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch
@@ -0,0 +1,53 @@
+From 516d184b5db8ebdd8b184ef871050c3ab3f03fdf Mon Sep 17 00:00:00 2001
+From: Andrew Chadwick <andrewc-git@piffle.org>
+Date: Sun, 21 Apr 2013 22:51:05 +0100
+Subject: [PATCH] SConstruct: support standard build environ vars
+
+Support the standard build environment vars CC, CXX, CFLAGS, CXXFLAGS,
+CPPFLAGS, and LDFLAGS everywhere.
+
+Partially addresses https://gna.org/bugs/?20754
+---
+ SConstruct | 19 +++++++++++++++++++
+ 1 file changed, 19 insertions(+)
+
+diff --git a/SConstruct b/SConstruct
+index 0b55da1..ef39b9e 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1,6 +1,7 @@
+ import os, sys
+ from os.path import join, basename
+ from SCons.Script.SConscript import SConsEnvironment
++import SCons.Util
+
+ EnsureSConsVersion(1, 0)
+
+@@ -45,6 +46,24 @@ print('using %r (use scons python_config=xxx to change)' % env['python_config'])
+ if sys.platform == "win32":
+ # remove this mingw if trying VisualStudio
+ env = Environment(tools=tools + ['mingw'], ENV=os.environ, options=opts)
++
++# Respect some standard build environment stuff
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('CPPFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CPPFLAGS'])
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CPPFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++if "$CCFLAGS" in env['CXXCOM']:
++ env['CXXCOM'] = env['CXXCOM'].replace("$CCFLAGS","")
++
+ opts.Update(env)
+
+ env.Append(CXXFLAGS=' -Wall -Wno-sign-compare -Wno-write-strings')
+--
+1.7.10.4
+
diff --git a/media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch b/media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch
new file mode 100644
index 000000000000..b992131bf29e
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch
@@ -0,0 +1,24 @@
+From: Andrew Chadwick <andrewc-git@piffle.org>
+Date: Tue, 8 Jan 2013 13:53:01 +0000
+Subject: desktop: remove deprecated Encoding key
+
+The Encoding key is deprecated as of 1.0 of the Desktop Entry Specification
+(8 Jan 2012)
+
+http://standards.freedesktop.org/desktop-entry-spec/1.0/apc.html
+---
+ desktop/mypaint.desktop | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/desktop/mypaint.desktop b/desktop/mypaint.desktop
+index 9850b54..24383db 100644
+--- a/desktop/mypaint.desktop
++++ b/desktop/mypaint.desktop
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+ Name=MyPaint
+ TryExec=mypaint
+ Exec=mypaint %f
+--
diff --git a/media-gfx/mypaint/files/mypaint-1.1.0-gentoo.patch b/media-gfx/mypaint/files/mypaint-1.1.0-gentoo.patch
new file mode 100644
index 000000000000..641ace05ea57
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-1.1.0-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ru mypaint-1.1.0-orig/desktop/mypaint.desktop mypaint-1.1.0/desktop/mypaint.desktop
+--- mypaint-1.1.0-orig/desktop/mypaint.desktop 2012-12-31 21:03:38.000000000 +0400
++++ mypaint-1.1.0/desktop/mypaint.desktop 2013-01-06 15:21:11.468785464 +0400
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+ Name=MyPaint
+ TryExec=mypaint
+ Exec=mypaint %f
+diff -ru mypaint-1.1.0-orig/SConstruct mypaint-1.1.0/SConstruct
+--- mypaint-1.1.0-orig/SConstruct 2012-12-31 21:03:38.000000000 +0400
++++ mypaint-1.1.0/SConstruct 2013-01-06 15:20:17.640771176 +0400
+@@ -1,6 +1,7 @@
+ import os, sys
+ from os.path import join, basename
+ from SCons.Script.SConscript import SConsEnvironment
++from SCons.Util import CLVar
+
+ EnsureSConsVersion(1, 0)
+
+@@ -75,6 +76,14 @@
+
+ env.Append(RPATH = env.Literal(os.path.join('\\$$ORIGIN')))
+
++for key in ['CC', 'CXX']:
++ if os.environ.has_key(key):
++ env[key] = os.environ[key]
++
++for key in ['CFLAGS', 'CXXFLAGS']:
++ if os.environ.has_key(key):
++ env[key] += CLVar(os.environ[key])
++
+ # remove libraries produced by earlier versions, which are actually
+ # being used if they keep lying around, leading to mysterious bugs
+ env.Execute('rm -f libmypaint-tests.so libmypaint.so libmypaintlib.so')
diff --git a/media-gfx/mypaint/files/mypaint-1.1.0-json-c-0.11.patch b/media-gfx/mypaint/files/mypaint-1.1.0-json-c-0.11.patch
new file mode 100644
index 000000000000..f2aa9b9a0edf
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-1.1.0-json-c-0.11.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=467322
+Patch-by: Helmut Jarausch <jarausch@igpm.rwth-aachen.de>
+Fixes pkgconfig name for new json-c (since 0.11)
+
+--- brushlib/SConscript.ORIG 2012-12-31 18:03:38.000000000 +0100
++++ brushlib/SConscript 2013-04-26 11:47:27.008232199 +0200
+@@ -73,7 +73,7 @@
+
+ env.Append(CPPPATH='./')
+
+-pkg_deps = ['json']
++pkg_deps = ['json-c']
+ libs = ['m']
+ linkflags = []
+
diff --git a/media-gfx/mypaint/metadata.xml b/media-gfx/mypaint/metadata.xml
new file mode 100644
index 000000000000..5e3a61a90139
--- /dev/null
+++ b/media-gfx/mypaint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-gfx/mypaint/mypaint-1.0.0-r1.ebuild b/media-gfx/mypaint/mypaint-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..b8aea36146bf
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.0.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+
+inherit eutils fdo-mime gnome2-utils multilib scons-utils toolchain-funcs python
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+LANGS="cs de en_CA es fr hu id it ja ko nb nn_NO pl pt_BR ru sl sv uk zh_CN zh_TW"
+for x in ${LANGS}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="dev-python/pygtk
+ dev-python/numpy
+ >=dev-python/pycairo-1.4
+ dev-libs/protobuf[python]"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig"
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" "${S}"/SConstruct || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${PN}-0.9.1-gentoo.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CXX
+ escons || die "scons failed"
+}
+
+src_install () {
+ escons prefix="${D}/usr" install || die "scons install failed"
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ find "${D}"/usr/share/locale/${x} -name "mypaint.mo" -exec rm {} \;
+ fi
+ done
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild b/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..574640f023a8
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2:2.5"
+
+inherit eutils fdo-mime gnome2-utils multilib scons-utils toolchain-funcs python
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="cs de en_CA en_GB es fr hu id it ja ko nb nn_NO pl pt_BR ro ru sl sv uk zh_CN zh_TW"
+for x in ${LANGS}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="
+ dev-python/pygtk:2
+ dev-python/numpy
+ >=dev-python/pycairo-1.4
+ dev-libs/protobuf[python]
+ >=dev-libs/json-c-0.11:=
+ media-libs/lcms:2
+ media-libs/libpng:0=
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig"
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" \
+ SConstruct SConscript || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${P}-build-env-vars.patch
+ # fix mypaint.desktop
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ # pkgconfig patch for json-c-0.11. 467322
+ epatch "${FILESDIR}"/${P}-json-c-0.11.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CC CXX
+ escons
+}
+
+src_install () {
+ escons prefix="${D}/usr" install
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm -rf "${ED}"/usr/share/locale/${x} || die
+ fi
+ done
+
+ # not used and broken
+ rm -rf "${ED}"/usr/{include/,lib/libmypaint.a,lib/pkgconfig/} || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/media-gfx/mypaint/mypaint-1.1.0-r2.ebuild b/media-gfx/mypaint/mypaint-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..ed9dcf18c7a3
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.1.0-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime gnome2-utils multilib scons-utils toolchain-funcs python-single-r1
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="cs de en_CA en_GB es fr hu id it ja ko nb nn_NO pl pt_BR ro ru sl sv uk zh_CN zh_TW"
+for x in ${LANGS}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.4[${PYTHON_USEDEP}]
+ dev-libs/protobuf[python,${PYTHON_USEDEP}]
+ >=dev-libs/json-c-0.11:=
+ media-libs/lcms:2
+ media-libs/libpng:0=
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" \
+ SConstruct SConscript || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${P}-build-env-vars.patch
+ # fix mypaint.desktop
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ # pkgconfig patch for json-c-0.11. 467322
+ epatch "${FILESDIR}"/${P}-json-c-0.11.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CC CXX
+ escons
+}
+
+src_install () {
+ escons prefix="${D}/usr" install
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm -rf "${ED}"/usr/share/locale/${x} || die
+ fi
+ done
+
+ python_optimize "${D}"usr/share/${PN}
+ # not used and broken
+ rm -rf "${ED}"/usr/{include/,lib/libmypaint.a,lib/pkgconfig/} || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/mypaint/mypaint-1.1.0.ebuild b/media-gfx/mypaint/mypaint-1.1.0.ebuild
new file mode 100644
index 000000000000..acaf8e1bc88e
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.1.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+
+inherit eutils fdo-mime gnome2-utils multilib scons-utils toolchain-funcs python
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="cs de en_CA es fr hu id it ja ko nb nn_NO pl pt_BR ru sl sv uk zh_CN zh_TW"
+for x in ${LANGS}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="dev-python/pygtk
+ dev-python/numpy
+ >=dev-python/pycairo-1.4
+ dev-libs/protobuf[python]
+ >=dev-libs/json-c-0.11
+ >=media-libs/lcms-2.0
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig"
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" \
+ SConstruct SConscript || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${PN}-1.1.0-gentoo.patch
+ # pkgconfig patch for json-c-0.11. 467322
+ epatch "${FILESDIR}"/${P}-json-c-0.11.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CXX
+ escons || die "scons failed"
+}
+
+src_install () {
+ escons prefix="${D}/usr" install || die "scons install failed"
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ find "${D}"/usr/share/locale/${x} -name "mypaint.mo" -exec rm {} \;
+ fi
+ done
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ python_mod_cleanup /usr/share/${PN}
+}