summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/opencsg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/opencsg')
-rw-r--r--media-gfx/opencsg/Manifest1
-rw-r--r--media-gfx/opencsg/metadata.xml13
-rw-r--r--media-gfx/opencsg/opencsg-1.3.2-r1.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/opencsg/Manifest b/media-gfx/opencsg/Manifest
new file mode 100644
index 000000000000..c508e0d2b208
--- /dev/null
+++ b/media-gfx/opencsg/Manifest
@@ -0,0 +1 @@
+DIST OpenCSG-1.3.2.tar.gz 744712 SHA256 c790c92998f7113cb35cde825f81c5532755908a0a3f43c3c3c8df2326b3b925 SHA512 12c4308234d61ae013db62039974178d49a7298fb18c9d4e431d3629c75c808e0892c6553f1676d991b50d69e26eeb6d6da1f1eea6b8b2785d06683f523ca0d8 WHIRLPOOL ed59764c861ede60dd430ad111613de92c44bbe6b9d5f33f6c0aee93671b7abb9ef266627f126820c877ee54a651aa0d560beaf1458cbce952e30ed88a6bf908
diff --git a/media-gfx/opencsg/metadata.xml b/media-gfx/opencsg/metadata.xml
new file mode 100644
index 000000000000..c90d92f5ccd0
--- /dev/null
+++ b/media-gfx/opencsg/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>mattm@gentoo.org</email>
+<name>Matthew Marlowe</name>
+</maintainer>
+<longdescription>
+OpenCSG is a library that does image-based CSG rendering using OpenGL. OpenCSG is written in C++ and supports most modern graphics hardware using Microsoft Windows or the Linux operating system. What is CSG, anyway? CSG is short for Constructive Solid Geometry and denotes an approach to model complex 3D-shapes using simpler ones. I.e., two shapes can be combined by taking the union of them, by intersecting them, or by subtracting one shape of the other. SG is often used as fundamental modeling technique in CAD/CAM applications. Here, image-based CSG rendering is the key to interactively manipulate CSG shapes. Since OpenCSG renders even complex CSG shapes fast, it can be advantageously used in such applications. The OpenCSG library requires graphics hardware that either supports frame buffer objects or PBuffers in OpenGL.
+</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild b/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..fcc92050d995
--- /dev/null
+++ b/media-gfx/opencsg/opencsg-1.3.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="The Constructive Solid Geometry rendering library"
+HOMEPAGE="http://www.opencsg.org"
+SRC_URI="http://www.opencsg.org/OpenCSG-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="media-libs/glew dev-qt/qtcore:4"
+DEPEND="${CDEPEND} sys-devel/gcc"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/OpenCSG-${PV}"
+
+src_prepare() {
+ # removes duplicated headers
+ rm -r "${S}"/glew || die
+
+ # We actually want to install something
+ cat << EOF >> src/src.pro
+include.path=/usr/include
+include.files=../include/*
+target.path=/usr/$(get_libdir)
+INSTALLS += target include
+EOF
+
+}
+
+src_configure() {
+ eqmake4 "${S}"/src/src.pro
+}