summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-08-11 14:14:59 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-14 12:39:10 +0100
commit0ba534ffc7995382d92438f2a57208ee886f6614 (patch)
tree7feac799cb1440e546ece4f6b5d8d485b6a80f47 /media-gfx/openvdb/files
parentnet-wireless/aircrack-ng: support libressl (diff)
downloadgentoo-0ba534ffc7995382d92438f2a57208ee886f6614.tar.gz
gentoo-0ba534ffc7995382d92438f2a57208ee886f6614.tar.bz2
gentoo-0ba534ffc7995382d92438f2a57208ee886f6614.zip
media-gfx/openvdb: revision bump to 4.0.2-r2
Remove unused inherit in 4.0.2 ebuild Fixed unittests and add test use flag Fixed boost linker errors removed unused option as it was Win32 only Closes: https://bugs.gentoo.org/660278 Update manifest for upcoming v5 release and fix descriptions Closes: https://github.com/gentoo/gentoo/pull/9535
Diffstat (limited to 'media-gfx/openvdb/files')
-rw-r--r--media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch16
1 files changed, 13 insertions, 3 deletions
diff --git a/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch b/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch
index 12245be3e466..fbb29883fe2f 100644
--- a/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch
+++ b/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch
@@ -1,11 +1,21 @@
---- openvdb-4.0.2/openvdb/python/CMakeLists.txt.orig 2018-07-12 20:29:50.745624805 +0200
-+++ openvdb-4.0.2/openvdb/python/CMakeLists.txt 2018-07-12 20:30:10.452305180 +0200
+diff -urN a/openvdb/python/CMakeLists.txt b/openvdb/python/CMakeLists.txt
+--- a/openvdb/python/CMakeLists.txt 2017-07-31 19:16:32.000000000 +0100
++++ b/openvdb/python/CMakeLists.txt 2018-08-11 12:37:40.179360277 +0100
@@ -3,7 +3,7 @@
FIND_PACKAGE ( PythonInterp REQUIRED )
FIND_PACKAGE ( PythonLibs REQUIRED )
-FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python )
-+FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR} )
++FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} )
IF ( NOT OPENVDB_BUILD_CORE )
+@@ -92,7 +92,7 @@
+ ${GLFW_LINK_LIBRARY}
+ ${GLFW_DEPENDENT_LIBRARIES}
+ ${GLEW_GLEW_LIBRARY}
+- ${Boost_PYTHON_LIBRARY}
++ ${Boost_LIBRARIES}
+ ${PYTHON_LIBRARY}
+ ${Ilmbase_HALF_LIBRARY}
+ )