summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-18 12:36:18 +1000
committerSam James <sam@gentoo.org>2020-08-24 14:41:49 +0100
commitcdb48fb7dff718b541d13aefafdf53d5cd4fccbc (patch)
tree7dc9b0d4d8a7ecac27ab7fda3720cc60e8512c25 /media-gfx/openvdb/files
parentmedia-gfx/openvdb: Update to EAPI 7 and switch to cmake eclass (diff)
downloadgentoo-cdb48fb7dff718b541d13aefafdf53d5cd4fccbc.tar.gz
gentoo-cdb48fb7dff718b541d13aefafdf53d5cd4fccbc.tar.bz2
gentoo-cdb48fb7dff718b541d13aefafdf53d5cd4fccbc.zip
media-gfx/openvdb: Fix build failure with newer c-blosc and doc
The c-blosc 1.19 function blosc_compcode_to_compname now expects a const char** rather than char**. This patch uses const_cast to fix the compiler error. When building with doc USE flag enabled, the doc target is not built by default and the missing docs cause an install failure. This patch ensures that when the doc target is defined, it will be built. With these two patches, openvdb builds with all USE flags enabled. Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Closes: https://bugs.gentoo.org/734102 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/openvdb/files')
-rw-r--r--media-gfx/openvdb/files/openvdb-4.0.2-fix-build-docs.patch12
-rw-r--r--media-gfx/openvdb/files/openvdb-4.0.2-fix-const-correctness-for-unittest.patch12
2 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/openvdb/files/openvdb-4.0.2-fix-build-docs.patch b/media-gfx/openvdb/files/openvdb-4.0.2-fix-build-docs.patch
new file mode 100644
index 000000000000..25597ec381d7
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-4.0.2-fix-build-docs.patch
@@ -0,0 +1,12 @@
+diff -Naur a/openvdb/CMakeLists.txt b/openvdb/CMakeLists.txt
+--- a/openvdb/CMakeLists.txt 2020-08-18 12:17:15.261321103 +1000
++++ b/openvdb/CMakeLists.txt 2020-08-18 12:17:37.101397373 +1000
+@@ -394,7 +394,7 @@
+ FILE ( WRITE ${CMAKE_CURRENT_BINARY_DIR}/cmake-doxygen-config ${DOXYGEN_CONFIG_CONTENT} )
+ FILE ( APPEND ${CMAKE_CURRENT_BINARY_DIR}/cmake-doxygen-config "OUTPUT_DIRECTORY=${CMAKE_CURRENT_BINARY_DIR}/doc\n" )
+
+- ADD_CUSTOM_TARGET ( doc
++ ADD_CUSTOM_TARGET ( doc ALL
+ ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/cmake-doxygen-config
+ WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
+ COMMENT "Generating API documentation with Doxygen" VERBATIM
diff --git a/media-gfx/openvdb/files/openvdb-4.0.2-fix-const-correctness-for-unittest.patch b/media-gfx/openvdb/files/openvdb-4.0.2-fix-const-correctness-for-unittest.patch
new file mode 100644
index 000000000000..8d3ef59e3ab1
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-4.0.2-fix-const-correctness-for-unittest.patch
@@ -0,0 +1,12 @@
+diff -Naur a/openvdb/unittest/TestFile.cc b/openvdb/unittest/TestFile.cc
+--- a/openvdb/unittest/TestFile.cc 2019-09-15 01:05:30.716633230 +0800
++++ b/openvdb/unittest/TestFile.cc 2019-09-15 01:06:16.126633668 +0800
+@@ -2552,7 +2552,7 @@
+
+ for (int compcode = 0; compcode <= BLOSC_ZLIB; ++compcode) {
+ char* compname = nullptr;
+- if (0 > blosc_compcode_to_compname(compcode, &compname)) continue;
++ if (0 > blosc_compcode_to_compname(compcode, const_cast<const char **>(&compname))) continue;
+ /// @todo This changes the compressor setting globally.
+ if (blosc_set_compressor(compname) < 0) continue;
+