summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-03 14:17:31 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-03 15:59:31 -0600
commitc0bd9d5726318bb882c8c20d741f9998595a0ec9 (patch)
treefa613ca6543d5ba0916ae622cc23542af914fe45 /media-gfx/panini
parentsys-apps/portage: revbump to 2.3.68-r1 (diff)
downloadgentoo-c0bd9d5726318bb882c8c20d741f9998595a0ec9.tar.gz
gentoo-c0bd9d5726318bb882c8c20d741f9998595a0ec9.tar.bz2
gentoo-c0bd9d5726318bb882c8c20d741f9998595a0ec9.zip
media-gfx/panini: version bump to 0.73.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-gfx/panini')
-rw-r--r--media-gfx/panini/Manifest1
-rw-r--r--media-gfx/panini/panini-0.73.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/panini/Manifest b/media-gfx/panini/Manifest
index 316fb25f6813..f33c04211e3a 100644
--- a/media-gfx/panini/Manifest
+++ b/media-gfx/panini/Manifest
@@ -1 +1,2 @@
DIST panini-0.72.0.tar.gz 328528 BLAKE2B b5053147d51f308395d2c3505bc0821947cd2c32955f86071cbbdd00c750793729be723c133ec7a619ff0fce5a0d9813580954597137a4e66780390b882bca7f SHA512 b859e723832d2d57de69dcbcd09615245e11d7fce124a55f7795608a8e9337427d9d1d10867ef9eecb16bd792313f5146ae19de553603bd70dedca69ba7c2de1
+DIST panini-0.73.0.tar.gz 329164 BLAKE2B 1cd592d7c5cf230398a6496a27f8389375a670b1de1a0f6acdb2027884bc5059798ad86ad4deb7795402654b3eb9edf112c3c177c7c716d55a186e48e1567f1c SHA512 4c12c0af5f94079f0da8f08dd19d99fd06c16c653b21532eba01022ed5b78afdcea2a042902fd50d0ea442483699cfdf9b10fd7f4592e3bae60abd5d2dabf657
diff --git a/media-gfx/panini/panini-0.73.0.ebuild b/media-gfx/panini/panini-0.73.0.ebuild
new file mode 100644
index 000000000000..32106c228518
--- /dev/null
+++ b/media-gfx/panini/panini-0.73.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg-utils
+
+MY_P="${P/p/P}-src"
+DESCRIPTION="OpenGL-based panoramic image viewer"
+HOMEPAGE="https://github.com/lazarus-pkgs/panini"
+SRC_URI="https://github.com/lazarus-pkgs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ virtual/glu
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+DOCS=( NEWS {BUILD,README,USAGE}.md )
+
+src_prepare() {
+ default
+ eqmake5 ${PN}.pro
+}
+
+src_install() {
+ einstalldocs
+ dobin panini
+ domenu "${FILESDIR}"/${PN}.desktop
+ newicon ui/panini-icon-blue.jpg ${PN}.jpg
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}