summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pixie/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pixie/files')
-rw-r--r--media-gfx/pixie/files/Makefile.shaders15
-rw-r--r--media-gfx/pixie/files/pixie-2.2.6-autotools.patch22
-rw-r--r--media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch73
3 files changed, 110 insertions, 0 deletions
diff --git a/media-gfx/pixie/files/Makefile.shaders b/media-gfx/pixie/files/Makefile.shaders
new file mode 100644
index 000000000000..fbc261c0c9bf
--- /dev/null
+++ b/media-gfx/pixie/files/Makefile.shaders
@@ -0,0 +1,15 @@
+SDRC = ../src/sdrc/sdrc
+SDRCFLAGS +=
+
+%.sdr: %.sl
+ $(SDRC) $(SDRCFLAGS) $<
+
+OBJECT1 := $(wildcard *.sl)
+OBJECT := $(OBJECT1:.sl=.sdr)
+
+all: clean $(OBJECT)
+
+clean:
+ rm -f *.sdr
+
+.PHONY: clean
diff --git a/media-gfx/pixie/files/pixie-2.2.6-autotools.patch b/media-gfx/pixie/files/pixie-2.2.6-autotools.patch
new file mode 100644
index 000000000000..d12de70a67cf
--- /dev/null
+++ b/media-gfx/pixie/files/pixie-2.2.6-autotools.patch
@@ -0,0 +1,22 @@
+--- src/ri/Makefile.in 2009-09-23 18:10:13.414866323 +0200
++++ src/ri/Makefile.in 2009-09-23 18:11:15.629864395 +0200
+@@ -214,7 +214,7 @@
+ host_os = @host_os@
+ host_vendor = @host_vendor@
+ htmldir = @htmldir@
+-includedir = $(prefix)/include
++includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+ libdir = @libdir@
+--- src/sdr/Makefile.in 2009-09-23 18:14:54.194865868 +0200
++++ src/sdr/Makefile.in 2009-09-23 18:15:18.297863856 +0200
+@@ -199,7 +199,7 @@
+ host_os = @host_os@
+ host_vendor = @host_vendor@
+ htmldir = @htmldir@
+-includedir = $(prefix)/include
++includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+ libdir = @libdir@
diff --git a/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch b/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch
new file mode 100644
index 000000000000..6d022f02fdb1
--- /dev/null
+++ b/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch
@@ -0,0 +1,73 @@
+http://bugs.gentoo.org/406899
+
+--- src/ri/rib.l
++++ src/ri/rib.l
+@@ -17,7 +17,7 @@
+
+ // Overwrite the YYinput so that it uses libz
+ #undef YY_INPUT
+-#define YY_INPUT(buf, retval, maxlen) if ( (retval = gzread(ribin,buf,maxlen)) < 0) \
++#define YY_INPUT(buf, retval, maxlen) if ( (retval = gzread((gzFile)ribin,buf,maxlen)) < 0) \
+ YY_FATAL_ERROR( "input in flex scanner failed" );
+
+ #endif
+@@ -223,7 +223,7 @@
+ TRibFile *nextFile = ribStack->next;
+ rib_delete_buffer( YY_CURRENT_BUFFER );
+ #ifdef HAVE_ZLIB
+- gzclose(ribin);
++ gzclose((gzFile)ribin);
+ #else
+ fclose(ribin);
+ #endif
+@@ -243,7 +243,7 @@
+ rib_delete_buffer( YY_CURRENT_BUFFER );
+
+ #ifdef HAVE_ZLIB
+- gzclose(ribin);
++ gzclose((gzFile)ribin);
+ #else
+ fclose(ribin);
+ #endif
+--- src/ri/ribOut.cpp
++++ src/ri/ribOut.cpp
+@@ -162,7 +162,7 @@
+
+ #ifdef HAVE_ZLIB
+ if (outputCompressed) {
+- gzclose(outFile);
++ gzclose((gzFile)outFile);
+ } else {
+ fclose(outFile);
+ }
+--- src/ri/ribOut.h
++++ src/ri/ribOut.h
+@@ -237,7 +237,7 @@
+ const int l = vsprintf(scratch,mes,args);
+
+ #ifdef HAVE_ZLIB
+- if (outputCompressed) gzwrite(outFile,scratch,l);
++ if (outputCompressed) gzwrite((gzFile)outFile,scratch,l);
+ else fwrite(scratch,1,l,outFile);
+ #else
+ fwrite(scratch,1,l,outFile);
+@@ -258,7 +258,7 @@
+ const int l = vsprintf(scratch,mes,args);
+
+ #ifdef HAVE_ZLIB
+- if (outputCompressed) gzwrite(outFile,scratch,l);
++ if (outputCompressed) gzwrite((gzFile)outFile,scratch,l);
+ else fwrite(scratch,1,l,outFile);
+ #else
+ fwrite(scratch,1,l,outFile);
+--- src/ri/rib.y
++++ src/ri/rib.y
+@@ -2940,7 +2940,7 @@
+
+ if (ribin != NULL) {
+ #ifdef HAVE_ZLIB
+- gzclose(ribin);
++ gzclose((gzFile)ribin);
+ #else
+ fclose(ribin);
+ #endif