summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-01-17 00:44:15 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-01-17 00:44:29 +0100
commitc96727f6e1b60909d00ee8c6933c2773c19b2011 (patch)
treee0522c7a37061bfc96cd05eaf7b76bc9242c9b42 /media-gfx/plantuml
parentmedia-sound/teamspeak-client: remove unused file (diff)
downloadgentoo-c96727f6e1b60909d00ee8c6933c2773c19b2011.tar.gz
gentoo-c96727f6e1b60909d00ee8c6933c2773c19b2011.tar.bz2
gentoo-c96727f6e1b60909d00ee8c6933c2773c19b2011.zip
media-gfx/plantuml: bump to 1.2020.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx/plantuml')
-rw-r--r--media-gfx/plantuml/Manifest1
-rw-r--r--media-gfx/plantuml/plantuml-1.2020.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/plantuml/Manifest b/media-gfx/plantuml/Manifest
index a947021cf405..6a0c599a475c 100644
--- a/media-gfx/plantuml/Manifest
+++ b/media-gfx/plantuml/Manifest
@@ -1,2 +1,3 @@
DIST plantuml-1.2019.13.tar.gz 4552633 BLAKE2B f6ea05bdd1e4e3cf748dc4d48ca9a89f06246d135bfcc410ec1b2094d1e53ab6ae415c2b39a3fc56441d17999794c1862b95718932d6a20152550deaa42a6c0e SHA512 8d2a2520821a5f75c3508bf2598186718469c6cf2c411f3b975de1abbb4792be8ae70ec84da7ae0bf4668738ca052de5463701dafc5805f362876f1d770ad494
+DIST plantuml-1.2020.0.tar.gz 4552164 BLAKE2B c78da31cffbeb0cf1a8852e53d07126c9b0dc80bf12f36f1039c806651c6802dd63456610307836207158bc871c4e2a8d9cf12a80bafa9dbde3b2be29b02f2e8 SHA512 1c3a7f735a197e5fd044547a6c48f21c2ee774d553d3de82d4931b2684a56dc4ef8af5f524e6aa4eebcb16f214620f6c99c038101d6703f03642a5b94f124fa8
DIST plantuml-8046.tar.gz 2966063 BLAKE2B 8634fbccbcd0ae2038a5e611215dd4343baba5e9562c02d6ebfc2a9fe702359fd035f490a9fd06484c08431993792efd1b3afd35f2a9812fb052f92f3616e284 SHA512 2ddae800fb30c0e352b44ef06476f7d770c12d516d93fe6f82ec1f33dd3bc1cb3330ba4a0cc89e06daa6eec9a56dc772a4f901d441dea86a8ce82b8d298cdfd5
diff --git a/media-gfx/plantuml/plantuml-1.2020.0.ebuild b/media-gfx/plantuml/plantuml-1.2020.0.ebuild
new file mode 100644
index 000000000000..62b6323d8b9f
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2020.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="http://plantuml.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-java/ant-core:0
+ >=media-gfx/graphviz-2.26.3"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+
+ make_desktop_entry plantuml PlantUML
+}