summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-09 10:12:42 +0000
committerSam James <sam@gentoo.org>2021-01-09 10:36:05 +0000
commitc3ffec49f62b0e61ae73cc4c539448c085738b63 (patch)
tree3224d9211b0615501e6569bc672730d307e674b8 /media-gfx/quat/quat-1.20-r2.ebuild
parentmedia-libs/lastfmlib: port to EAPI 7, fix StaticSrcUri (diff)
downloadgentoo-c3ffec49f62b0e61ae73cc4c539448c085738b63.tar.gz
gentoo-c3ffec49f62b0e61ae73cc4c539448c085738b63.tar.bz2
gentoo-c3ffec49f62b0e61ae73cc4c539448c085738b63.zip
media-gfx/quat: modernise ebuild, inc. StaticSrcUri
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/quat/quat-1.20-r2.ebuild')
-rw-r--r--media-gfx/quat/quat-1.20-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/quat/quat-1.20-r2.ebuild b/media-gfx/quat/quat-1.20-r2.ebuild
new file mode 100644
index 000000000000..17e06e1566e8
--- /dev/null
+++ b/media-gfx/quat/quat-1.20-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A 3D quaternionic fractal generator"
+HOMEPAGE="http://www.physcip.uni-stuttgart.de/phy11733/quat_e.html"
+SRC_URI="http://www.physcip.uni-stuttgart.de/phy11733/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X debug"
+
+DEPEND="
+ >=sys-libs/zlib-1.1.4
+ X? (
+ =x11-libs/fltk-1*
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export FLUID="/usr/bin/fluid" # needed because configure tries an invalid option
+ econf \
+ $(use_enable X gui) \
+ $(use_enable debug) \
+ $(use_enable debug prof)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}