summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-01-14 19:07:44 +0100
committerSebastian Pipping <sping@gentoo.org>2018-01-14 19:10:29 +0100
commita91e8bcf4d45eb1332e18d42843d489ced7edff1 (patch)
tree46e1128f32834e66161488df7f7e744246ed01ee /media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
parentdev-python/pysaml2: cleanup for bug 644016 (diff)
downloadgentoo-a91e8bcf4d45eb1332e18d42843d489ced7edff1.tar.gz
gentoo-a91e8bcf4d45eb1332e18d42843d489ced7edff1.tar.bz2
gentoo-a91e8bcf4d45eb1332e18d42843d489ced7edff1.zip
media-gfx/raw-thumbnailer: Support libopenraw >=0.1
Closes: https://bugs.gentoo.org/609972 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild')
-rw-r--r--media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild b/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..8d3bedb4b406
--- /dev/null
+++ b/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A lightweight and fast raw image thumbnailer"
+HOMEPAGE="https://github.com/erlendd/raw-thumbnailer"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libopenraw-0.1:=[gtk]
+ x11-libs/gtk+:2
+ !media-gfx/gnome-raw-thumbnailer"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog )
+PATCHES=(
+ "${FILESDIR}"/${P}-libopenraw.patch # bug 609972
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}